BimmerFest BMW Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello E39 fans,

I have read alot of posts on this subject, but sadly am more confused then when I began. Here's my history. 2003 530i with 102K miles. Recently I replaced the cooling system, belts, tensioner and plugs. Two weeks later she won't start, just click, click, and flickering dash lights. Dead battery right. So I replace the battery, all is well. Two weeks later, click, click, again. AAA tow comes out and says the battery is fine, just bad connections. We clean them and she jumps starts right up. Two weeks later, click, etc., I try and clean the cables, no good. I jump her myself and after 5 minutes she starts. I got an emissions check engine code for about 1 mile (she ran terrible) then it goes out and she's fine. Back to the Autozone where I bought the new battery, they check it and say its fine. Two weeks later, you guessed it, click, click. This time she goes to my indy mechanic, who says the battery is completely dead and needs a replacement. He swaps out batteries, and thinks everything is OK. This time 2 days later, click, etc. My mechanic "load tests" the new battery and says there is a drain somewhere? He is now in the process of pulling fuses to see if we can track down the problem. I had him replace the FSR while he's was at it. He's says he's looking for a "bad relay" open?

So here we are. Any suggestions from this forum would be greatly appreciated.
 

·
Freude am Fahren
Joined
·
6,378 Posts
Ouch. Expensive car!

I can't remember if it was here or for my mom's Honda, but I think there's been a case where the CD changer doesn't stop changing CDs and drains the battery. Might that be it?

Bad relay could be it, easily. I hope you don't get hosed by your mechanic!
 

·
Registered
Joined
·
4,433 Posts
Hes doing the right thing by pulling fuses and checking the drain with a meter. Youll get nothing better than a guess from here, the drain could be anything from the trunk light staying on, to a bad blower motor resistor. Let us know what it was when he figures it out.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
update car won't start

After two weeks my mechanic said there was a bad relay in the alarm system. He gave the car to his friend at the dealer who indicated I had two bad door actuators. They were shorting out the relay to the alarm. The parts were $175 for each door. Does any of this sound familiar or make sense to anyone? Thanks again for the forum's help.
 

·
Registered
Joined
·
414 Posts
Yep, that sounds reasonable. If it fixes it, it fixes it. He went about it the right way and it sounds like it worked out in the end.
 

·
Registered
Joined
·
2 Posts
same problem

i have the same problem with the battery drain and so called "bad connection" but i also replaced thed battery with a new one and still no progress. all the lights on my dash go on and my running lights also turn on but no clicking sound. i had my buddy check all connections and fuses and everything seemd fine so im thinkin its my starter but im waitin to see wat happens because i brought it to my frends shop just today. was there any luck with your 530?
 

·
Registered
Joined
·
4 Posts
I feel your pain

Just went through the same ordeal. Here is the fix from elsewhere on the forum.

http://www.bimmerfest.com/forums/showthread.php?t=143393&highlight=e39+battery+drain

Its caused because a faulty sensor/relay keeps activating the ventilation system and waking up the car's computer. I went through two batteries, and lots of "diagnostic" charges from both my independent mechanic and the dealer. I found this forum and went through the tests. I brought the fix to my dealer and they acted surprised, but thought it would be logical. It was.
 
1 - 7 of 7 Posts
Top