BimmerFest BMW Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
:help:So the a few weeks ago I was driving home and all of a sudden my radio started to cut in and out and my gauge cluster started going haywire. Speedo, Tach, Fuel, Temp, MPG all went to max for no reason. However the car still ran and stopped fine.

I thought I had resolved this by pulling the negative terminal off of the battery for a little while and I checked all of my fuses. I reset my gauge cluster and things worked okay for a while and I thought the electrical gremlin got scared away. :harv:

But I was wrong, yesterday I get in and it happens again. :banghead::banghead::banghead::banghead::banghead::banghead: I'll have a video posted below.

So basically everything works OK, up to the point where I start the car and the cluster goes haywire and the radio loses some of its sound and cuts in and out. I turn off the car and radio goes back to normal..... You'll see in the video.

https://youtu.be/uFIPT0k-c1w

Has any one experienced this and could possibly provide a solution? Thanks guys!
 

·
Keeping it surreal
Joined
·
43,228 Posts
When a battery is near the end of it`s useful life, it is often the cause of many seemingly unrelated problems. How old is your battery ? Does your car ever sit unattended for periods of time ?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Hmmm.... As far as I know the battery has been replaced but not sure on timeframe. I do drive the car at least once or twice a week sometimes more.

But my wonder is how that stuff is effected by the battery if the car is running.
 

·
Keeping it surreal
Joined
·
43,228 Posts
Hmmm.... As far as I know the battery has been replaced but not sure on timeframe. I do drive the car at least once or twice a week sometimes more.

But my wonder is how that stuff is effected by the battery if the car is running.
These cars are extremely battery-sensitive. Read our E46 Wiki, and look into this:
Hidden Onboard Computer Functions
 

·
ROLL TIDE!
Joined
·
23,977 Posts
I'd be apt to try a new cluster if the battery tests good.
 

·
Registered
Joined
·
2,861 Posts
Yes, check battery and alternator first before doing anything else. Ensure your battery and charging system are performing properly. Only then can you find other problems.
 

·
Registered
Joined
·
197 Posts
Hmmm.... As far as I know the battery has been replaced but not sure on timeframe. I do drive the car at least once or twice a week sometimes more.
If those are short drives, your battery may just be depleted. If you have a battery tender or trickle charger, just charge it overnight and see what happens. Alternatively, go for a long drive on the highway (at least 30-40 min) and see if that gets rid of the symptoms. If not, get the battery and charging system tested, as suggested above.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8 (Edited)
So according to the Wiki our battery should be within at 12 when the car is off and around 14 when the car is on.

I did the battery test and noticed my battery was around 11, barely going up to 12. Once the car got turned on it went to 13-14 but no more than 14. I'm thinking battery but not sure, what do you guys think?

Video

https://youtu.be/D_Wpr0MEvcs

If those are short drives, your battery may just be depleted. If you have a battery tender or trickle charger, just charge it overnight and see what happens. Alternatively, go for a long drive on the highway (at least 30-40 min) and see if that gets rid of the symptoms. If not, get the battery and charging system tested, as suggested above.
The drives are typically going from my house into town, which is about 15-20 minutes and then driving around the small town and then another 15-20 minutes back home. Besides the onboard diagnostic functions are there any other ways to test the battery and charging system? I have an oreilly's auto in town, I think they do battery testing.
 

·
Registered
Joined
·
5,349 Posts
The video sez the voltage regulator is suspect. Have the battery checked first. If it's ok I suggest you change the voltage regulator.

In all likelihood you car has a 120amp Bosch alternator. Why? My 2001 330Ci has this alternator. Remove the air filter box and the upper intake hose. Use a flashlight and a mirror to read the label on the back of the alternator. It may say Valeo as BMW sourced 120amp alternators from Bosch and Valeo. They are not interchangeable! Hopefully it's a Bosch. A Bosch voltage regulator will cost about $50. You'll also need to buy part #3 in http://www.realoem.com/bmw/enUS/showparts?id=BN53-USA-07-2000-E46-BMW-330Ci&diagId=12_1084

Why? It'll be very brittle and will break when yo try to remove it. Ask me how I know. It's vital that this part and the other alternator cooling parts be reinstalled properly.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10 (Edited)
**Update** More :banghead: continues

So I put my battery charger / tender on the car this afternoon starting at 12:00 and 6:00 I go out and check the charger just flipped over to charged/tending. I disconnect the charger and jump in to see how things are going.

So the battery (after being charged) was at 12-13 before starting up

When I started the car up, the voltage went back down to 9 and creeped its way up to 14 and the gauges starting going haywire again.

So now should I still continue to try to charge the battery more / replace battery or look at other options such as alternator / voltage regulator?
 

·
Registered
Joined
·
46 Posts
Gauges going 'haywire'...

The one time my gauges went 'haywire' occurred when the fuse for the DME was accidentally left out (& the car also would not start). If your battery & charging system are O.K. and the gauge problem persists, you might want to investigate the I/K-bus.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
****update***

Went to Oreilly's Auto and had them test my original battery and they decided it was low so I allowed them to charge the battery. I left it with them overnight just for the heck of it, next day they tested the battery again and it had lost charge again. Before I could buy another battery myself, my father-in-law gifted me a new battery from Oreilly's. I installed the fresh battery and did not drive the car until today.

Today I get in and everything goes nuts again the same as before with the old battery. Now I am baffled as to what to do next, we all were pretty sure it was the battery. Now what should I check for?
 

·
ROLL TIDE!
Joined
·
23,977 Posts
****update***

Went to Oreilly's Auto and had them test my original battery and they decided it was low so I allowed them to charge the battery. I left it with them overnight just for the heck of it, next day they tested the battery again and it had lost charge again. Before I could buy another battery myself, my father-in-law gifted me a new battery from Oreilly's. I installed the fresh battery and did not drive the car until today.

Today I get in and everything goes nuts again the same as before with the old battery. Now I am baffled as to what to do next, we all were pretty sure it was the battery. Now what should I check for?
Someone mentioned a new cluster........:eeps:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
Someone mentioned a new cluster........:eeps:
That was my very first thought before others started mentioning battery. I don't get how it effects the cd player and possibly any other electrical issues while it is happening though. I don't really have the kind of money to throw at the car to get "maybe" fixes. I'm hoping to get it figured out and not have to spend more if I am wrong again.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #16
*update**

Well, I think I figured out the problem. On my way home from town today my headlights kicked on (I usually keep it on Auto) and the Cluster went crazy and the Radio cut in and out. I turned off the headlights and everything returned to normal. Got home, stopped and turned the headlights on again and it went nuts again, turned them off and everything went back to normal.

So maybe LCM, or something is shorted out in the headlight area?
 
1 - 16 of 16 Posts
Top