BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
HELP PLEASE!
I have a 1999 E39 with 5 speed auto/steptronic box. this weekend whilst driving the car, i just lost all gears. Felt like the car just went into neutral? No noise or any warning signs, just would not select any gears. I got the car off the road, engine was still running smoothly, but no gears could be selected. When i went through the gears selector and came back up to park only then would the box make a grating noise....

Please advise as to what the problem might be as i dont want the workshop to charge me for unnecessary repairs.. Is it the torque converter? :cry:
 

·
Registered
Joined
·
1,009 Posts
With the limited info given, I think the most likely thing is a broken or partially disconnected shift linkage. Automatics dont normally just lose all gears all of the sudden.
When you go through the shift positions, does the indicator on the dash follow?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Gears

Hey Fly, thanks for the fast response.

When i go through the gears, the shifter moves smoothly and the instrument displays reflects the movement. Even if i toggle through the gears 1-5 in "manual" mode the selected gear shows on the instument panel. No noise or jerking, only when shifter is returned to park.
 

·
Older than old school
Joined
·
4,461 Posts
It sure sounds like no movement is getting past the torque converter. If you could get it up on a lift, you might be able to tell if anything is spinning inside the transmission itself.
 

·
Registered
Joined
·
1,009 Posts
Its probably stuck in P or N. The shifter moves a cable linkage to the transmission selector. Im pretty sure the cable has come loose and needs tightening/adjustment. It does not sound like the transmission has gone bad. If Im right, its a simple fix that would take 5 min if you could get under the car, unless the cable has broken. But Ive never heard of that happening.




.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
gears

Thanks guys, the car is at the shop right now and i am certainly hoping its only a loose or broken cable. As soon as i know i will post again.
 
1 - 6 of 6 Posts
Top