BimmerFest BMW Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Hello I have a 2007 bmw 328i it was working and then the next day it wouldn't turn on. I think it's the battery but I'm not sure. When I turn it on I hear a click and the cluster lights go dim. Does it seem like the battery? I'm going to take it to get charged tomorrow so hopefully that is it but any input would be great. Also the battery sign would come on for a little bit after I would turn it off a few weeks before it stopped working. Was it telling me it was going out ? Thank you in advance
 

·
Registered
Joined
·
2,187 Posts
More than likely it is the battery. Recharging won't help. It will die again and leave you stranded. Even a battery that is jump started may not work again after the car is turned off as the battery won't take a good charge when it goes bad. The car requires a lot of the battery even when it is off.
 

·
Registered
Joined
·
6,103 Posts
If you take it somewhere to change the battery

If you take it somewhere to change the battery
do not let them use a battery back up device when changing
the battery as it will blow the instrument cluster fuse.
If its on the original battery it for sure needs a new one.
Yes the battery sign should be heeded.
Usually weird stuff starts happening even before the low battery indicator comes
on.
Try to go to an independent BMW shop if you can't change the battery
yourself because places like autozone or pepboys will likely screw it up.

You need a battery tender if you don't drive the car a lot as its always
using some battery power even when its sleeping.

http://www.bimmerfest.com/forums/showthread.php?t=936293&highlight=instrument+cluster
 

·
Registered
Joined
·
77 Posts
Hello I have a 2007 bmw 328i it was working and then the next day it wouldn't turn on. I think it's the battery but I'm not sure. When I turn it on I hear a click and the cluster lights go dim. Does it seem like the battery? I'm going to take it to get charged tomorrow so hopefully that is it but any input would be great. Also the battery sign would come on for a little bit after I would turn it off a few weeks before it stopped working. Was it telling me it was going out ? Thank you in advance
Check you clamps. If one is loose it'll do that to you. You can try recharging it and see how it keeps its charge or if it even took charge. If no good then go ahead and buy a new battery.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #5
Check you clamps. If one is loose it'll do that to you. You can try recharging it and see how it keeps its charge or if it even took charge. If no good then go ahead and buy a new battery.
We changed the battery and it fired right up drove about a mile and it started showing the yellow overheating sign and then went to red pulled over added the small amount of coolant that we had and drove a little further the yellow light came back on never went to red the fan turned on but not extremely loud. We had it towed home. My question is could a fuse in the wrong place have caused this? We found a fuse that may have been misplaced when it was being troubleshooted when the battery went out and put it where we think it belongs and right away we heard the water pump start working and pushing out air bubbles. What do you think?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #6
More than likely it is the battery. Recharging won't help. It will die again and leave you stranded. Even a battery that is jump started may not work again after the car is turned off as the battery won't take a good charge when it goes bad. The car requires a lot of the battery even when it is off.
We changed the battery and it fired right up drove about a mile and it started showing the yellow overheating sign and then went to red pulled over added the small amount of coolant that we had and drove a little further the yellow light came back on never went to red the fan turned on but not extremely loud. We had it towed home. My question is could a fuse in the wrong place have caused this? We found a fuse that may have been misplaced when it was being troubleshooted when the battery went out and put it where we think it belongs and right away we heard the water pump start working and pushing out air bubbles. What do you think?
 

·
Registered
Joined
·
2,007 Posts
We changed the battery and it fired right up drove about a mile and it started showing the yellow overheating sign and then went to red pulled over added the small amount of coolant that we had and drove a little further the yellow light came back on never went to red the fan turned on but not extremely loud. We had it towed home. My question is could a fuse in the wrong place have caused this? We found a fuse that may have been misplaced when it was being troubleshooted when the battery went out and put it where we think it belongs and right away we heard the water pump start working and pushing out air bubbles. What do you think?
I think you better take it to somebody who knows BMW cars before you do more damage..
 

·
Registered
Joined
·
2,187 Posts
Ok... The waterpump wouldn't cause the battery to go out but av pump that isv drawing more current than the fuse can handle should blow the fuse. A pump that won't work will trigger the AUX fan to crank at full speed. Are the fuses ok? Have you checked yet?
 

·
Registered
Joined
·
33 Posts
Discussion Starter #12
We checked the fuse and one was in the wrong spot after that it's been working great even when it was "overheating" the fans never turned on extremely loud it was pretty quiet actually. We did the purge procedure and the water pump started working and pushing out air bubbles and it's been fine ever since we've driven it even on the freeway when yesterday we only got about a mile before the signs came up
 

·
Registered
Joined
·
2,187 Posts
Cool deal. If your pump was bad, it would still be popping up even after the fuse swap and telling you to pull over. I replaced my own pump. Happened at 86k miles to me.
 

·
Banned
Joined
·
10,015 Posts
We found a fuse that may have been misplaced when it was being troubleshooted when the battery went out and put it where we think it belongs and right away we heard the water pump start working and pushing out air bubbles. What do you think?
What fuse & where? For our education....
 
1 - 14 of 14 Posts
Top