BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
I have a 2000 528i that is having some problems. It seems to idle really rough when I start it up. There are a few lights on in the dashboard. the {!} and Check Engine Light and now the { } has come on. We have replaced the ignition coils thinking this could be the problem. It started to idle better but has now regressed back to what it was before we had that work done. I need to leave to go out of town on Monday morning and needed to take this car, but wanted to check and see what everyone thought of driving it under these circumstances/problems. ANY help would be great! Does anybody know what this problem could be??
 

·
Technical Graphite > ALL
Joined
·
446 Posts
I think you already know the answer, and it isn't "Yes".
 

·
Freude am Fahren
Joined
·
6,378 Posts
Parking brake ( ! )
Brake pads ( o )
Read your owner's manual, save money!

Get the codes read, probably a quick (maybe even cheap) fix! Also see beisansystems.com to improve your idle
 

·
Registered
Joined
·
790 Posts
Pull some codes, and No.

Drive it like that, and there'll be a running pool of several of us betting $100 when something will go catastrophically wrong. Bench the car, pull the codes, take the bus if you have to. Just don't move it anymore.


Wait - Why'd you replace all the coils without knowing what to do first?

Not trashing you, just curious.

Edit #2 - I agree with BMW noob, check out Beisans Systems.

Vanos on these cars has a tednacny to go out after a while, due to BMW being AWESOME and using Buna/Nitrile Orings... Which is great for applications like paintball guns, but useless for applications with constant head and temperature modulation.

Edit 3 - I've got a PDF of the manual laying around here somewhere...
 
1 - 5 of 5 Posts
Top