BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I previously had a Dinan kit installed on my 320ix 2018 in October. It was driving fine until the other day and a message for the drivetrain came up as a notification IMG_5503.jpg

. It has been driving a bit sluggish. Do you think it could be the kit causing the issue or maybe it wasn’t installed correctly? (This is not my expertise)But wanted to see if anyone had some experience with the kit.
Thanks!
 

·
Registered
Joined
·
670 Posts
i suggest you contact dinan. they have good tech support
 

·
Aviator
Joined
·
2,930 Posts
Why are you assuming it has something to do the with Dinan tuner? More likely a BMW sensor or Valvetronic issue or ?? The Dinan tuner merely piggybacks on the BMW map.

I'd take it to a dealer, but a Dinan authorized dealer would be better. Doubt if you will get anything useful out of Dinan CS
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
Why are you assuming it has something to do the with Dinan tuner? More likely a BMW sensor or Valvetronic issue or ?? The Dinan tuner merely piggybacks on the BMW map.



I'd take it to a dealer, but a Dinan authorized dealer would be better. Doubt if you will get anything useful out of Dinan CS


dkreidel I only assume the dinan kit since its the most recent thing I have added to the car. I took the car to my BMW dealer for them to look at it and they said the same thing it’s the dinan kit and they what to disconnect it and see if the notification comes up again.
I will get in contact with another dealer here that is Dinan authorized. Thanks for the info.
 
1 - 5 of 5 Posts
Top