BimmerFest BMW Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
'94 320i Hesitates at low RPM, sometimes missfires when you blip the throttle when its ticking over. It's also difficult to start.
Changed the 02 sensor and it improved a bit but not that much. Been told that it might be a crank sensor fault, does this sound possible? and is there a way I can test it?
Any help would be greatly appreciated.
Cheers,
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #2 ·
Went to get a crank sensor from local breakers today £15+vat went down there. And the guy breaks it getting it out, didn't have any more! Arrghh!
 

·
Registered
Joined
·
48 Posts
I had the same problem when I got my bummer, I fixed it by replacing the spark plugs, the coil boots, an the valve cover gasket. The valve cover gasket was leaking oil into the spark plug cylinders an had deteriorated the boots and was insulating the against the spark. After I replaced those parts I had no more missfires or engine stutters. Hope that helps some
 

·
Registered
Joined
·
369 Posts
My car had a miss fire do to a oil in a spark plug from a valve caver gasket went bad check that.
 

·
Registered
Joined
·
48 Posts
...when I got my bummer, I fixed it by replacing ...
I just noticed that my iPhone replaced bimmer with bummer... :yikes: and I don't want to call my car a bummer, cause its definitely not :D (and it wont let me edit my previous post for some reason...)
 
1 - 7 of 7 Posts
Top