BimmerFest BMW Forum banner

"High Battery Drain" issue

1 - 15 of 15 Posts

·
Registered
Joined
·
831 Posts
Discussion Starter · #1 ·
I have a 2007 530xi.

Started getting a "check control" message on start up: "High Battery Drain".

Found a couple of good threads that discuss this issue, but wanted to check-in again with the collective wisdom now that I assume many people that had this issue have solve it.
 

·
Registered
Joined
·
1,971 Posts
I had CIP / Progman 25.1.2 installed (target data status: E060-07-03-525) in May and it has not re-occurred.
 

·
Registered
Joined
·
726 Posts
We had a client with an 06 E61 with this message that did not go away after having the software update performed. It turned out the car was taking forever to go to sleep (up to 45 minutes), and then waking up for no apparent reason intermittently and draining the battery in the process.

The techs were able to catch it doing this - turned out to be a radio module IIRC - also the only car that I have seen that was not cured by the software update.

I also think that it was certain 06's, and not 07's that were affected/cured by the reprogram, but not 100% sure on this.......
 

·
Ich liebe mein BMW
Joined
·
3,761 Posts
That happened to my 06 525.
I had this same message pop up on my idrive every time the car sat longer than 7 hours. Took it to the dealer, they updated the software and fixed the problem. I will have to see the paperwork after work.
 

·
Registered
Joined
·
198 Posts
Happened to me. They upgraded the software, but that didn't work, so now they are replacing the TCU. My car's been sitting at the dealer since last Thursday waiting for the TCU to be sent over from Germany.
 

·
Registered
Joined
·
831 Posts
Discussion Starter · #7 ·
Hi Sherry,

My high battery drain warning has gone away. However, I read somewhere that the CD player may not always power down after turning "off" the car. So for the past couple of weeks I simply haven't been using the CD player. There was a correlation between not using the CD player and not getting this warning, but I'll try using the CD player to see if the warning comes back.

If so, I believe the fix is to have the dealership update to the latest iDrive software.

Why do you think it might be your TCU (and what is a TCU)?
 

·
Registered
Joined
·
4 Posts
High Battery Drain

The BMW garage said they had another car in with the same issue, the high battery drain. They told me it was the TCU on that car. The TCU is the telecom communication unit, the bluetooth and how you communicate with SOS (Onstar).
 

·
Registered
Joined
·
198 Posts
Yes, it was my TCU. They replaced it (after upgrading the software on the car as the first attempt to fix) and it has gone away. I was getting both a high battery drain and an SOS error at the same time. Both are gone now.
 

·
Registered
Joined
·
201 Posts
The dealer told me I needed to lock my vehicle while it is in the garage as every time I am near it with the key it go into ready mode and starts draining the battery. Frankly, I think that'a a bunch of bull since I drove it several hundred miles the day before and got "won't start if shut off" message the next day. Deler staes it is a low voltage issue and that the new "Efficient Dynamics" models only charge when coasting so no matter how long you drive, the battery may not receive a full charge.

My spouse had the same vehicle with fewer accessories and also without xdrive and never has had a problem. And she drives even less than I do!

BMW is likely going to someone else next week and I'm going to something less computer controlled like a good ole muscle car from the 60's.
 

·
Tail out!
Joined
·
365 Posts
Uhhhh... One, this is the E60 forum... Have you tried the F10 folks? And two...

HOLY THREAD REVIVAL, BATMAN! This thread died in 2007... :yikes:
 

·
Registered
Joined
·
201 Posts
Hey, we're both in Sun Diego. Everyone has the same issues, but found more info here in your forum than in the F07 where my GT resides. Or will until Monday. Sad end to a great ride and we have two of the beasts. But I just can't depend on mine to tell me if something is really going wrong or not. As you know from our climate, the sweat starts forming in really uncomfortable places when you're in Octillo Wells in summer and one of those warnings goes off, for no reason, no matter how high the A/C is cranked!

Be safe and enjoy the now dry weekend!
 

·
Registered
Joined
·
108 Posts
I replaced the battery. That's when it happened. Had to call for instructions from Autoenginuity for the resetting procedure.
It worked and the message hasn't returned.
 

·
Registered
Joined
·
204 Posts
I thought the warning is normal when you discharge the battery beyond the norm. I got the message when I was on a call through bluetooth after I had shut the engine off. The next day when I started the car, the same warning reappeared. But, it went away after I drove the car for about 15 minutes. It happened again, when my son didn't close the rear door all the way and the interior light stayed on. Again, the warning disappeared after I drove the car some distance the next day.
 

·
Registered
Joined
·
1,418 Posts
Convenient pkg is bad combination for this car. Replced some sensor on door handle.
 
1 - 15 of 15 Posts
Top