BimmerFest BMW Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So I bought a 2006 525xi about a year ago, throughout this year many problems have occurred, but I have managed to fix it all. Except for the latest little but big problem. About 4 months ago my car stopped turning on, took it to the dealership, and they said that it was the starter. I replaced the starter. But the problem persisted, then the battery was diagnosed to be bad (10 years old), dealership replaced and registered it. However, the problem persisted the same day. I am curious if you guys have any ideas what the problem could be so I can be prepared to hear the dealerships new ideas.

Problem:
-car won't turn on after it runs and cools for a couple minutes (sometimes).
-After sitting for about an hour and a half it restarts
-It will start as many times afterwards when parked for a while

So here is what I have tried:
-Checking the fuses, all good
-heat soak- drove enough to heat the car, arrived home, turned it off and on again. It was successful, car turned on. Waiting for car to not turn on to give it the little love tap on the starter and see if it works.
-Battery is full and well.
-There is enough Fuel, and it circulates well. Fuel pump is also new.

Any new ideas?
 

·
Registered
Joined
·
29 Posts
Have you pulled any new or stored codes?

When you try to start the car, do the electronics turn on but the engine doesn't turn over, or is the entire car dead?
 

·
Registered
2006 530xi 6 MT
Joined
·
5,232 Posts
I could swear I remember reading some thread recently about something similar and it sounded similar to what you saying. Something to do with the gas tank or refueling. Some sensor or pump or something like that related to the gas tank.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
I could swear I remember reading some thread recently about something similar and it sounded similar to what you saying. Something to do with the gas tank or refueling. Some sensor or pump or something like that related to the gas tank.
Read that too, sensor is also new, though. I updated them a little before the starter. Checked to see if there was any odd noises by the tank, all seemed well. I'll recheck.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 ·
Quick update: I drove it a fair amount, when I reached my destination I turned it off and on expecting the car not to turn on anymore. But it did. I'm thinking it's having to do something about the heat, today my car has been kept cool due to rain and wind. Unlike yesterday when it was sunny and hot. I have driven this distance before with the car still all day and have it not turn on a second time.
 

·
Registered
Joined
·
1,183 Posts
Your going to have to test the starter circuit when the car won't start. It's not the easiest thing to do given the location of the starter. Basically what you need to do is verify that there is power to the starter on the main cable at the starter. Next you need to make sure that the solenoid wire at the starter is supplied with 12 volts when someone attempts to start the engine. If both of these items test good then you need a starter. Typically when starters go bad they have issues when they are hot but then function when things cool down. I'm betting the starter you bought is no good. A word of advice....don't buy cheap starters, you'll get what you didn't pay for. Not saying that you purchased a cheap starter but just saying.
 
1 - 9 of 9 Posts
Top