BimmerFest BMW Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
so yea ever since i replaced my timing belt ive had nothing but weird **** going on. first the battery was dead as hell, now that it is back up i filled the resevior bottle up with coolant and started the car for about a minute. then turned it off and checked the coolant . i then topped it back off and started it again(just trying to cycle the coolanty into the radiator and the motor.) So any ways i was squeezing the rubber hoses and nothing, i cant seem to get any coolant into the radiator or into the hoses. and i even tried getting it hot and taking the bleed screw out to let the air out and I thought all the air was out and went for a drive. aftre about 2 minutes the temp gauge just started climbing into the red. i immediatly parked it and let it cool. also my fan is not coming on.. im just wandering does any body have a schematic of the cooling system or a page out of there service manuall on th cooling section including service and trouble shoot. the car is also idling weird as ****. idling at around 500 rpms and if you listen to the exhaust pipe its not a steady growl it has a pulse to it. my bently is on its way because i dropped my coolant jug that had old coolant in it on my haynes manuall which was a useless piece of **** book any ways. can you guys help me?????
 

·
another E30 nut
Joined
·
916 Posts
there are 2 ways. Top of radiator, bleeder screw OR since yours is an 85. The top of the thermostat housing. ITs a bleeder screw with a square head. Cant miss it.
Be careful of the obvious hot fluids spraying out.

EDIT: Oh and burn the hayes manual
 
1 - 2 of 2 Posts
Top