BimmerFest BMW Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
4,028 Posts
Discussion Starter #1 (Edited)
Anybody knows how to re-calibrate the Steering Angel Sensor? I think by me disconnecting the battery over a long period has caused an issue with steering angle and the damn thing is intermittently throwing Traction control light.

Thanks guys.
 

·
Registered
Joined
·
4,108 Posts
There is still some debate on this: via software or manual calibration. Let us know...

you can communicate with the dsc with creator 310, i have it, you do not need anything but the car running to calibrate the sensor

you while Running and @ a stop

turn left full hold 2 seconds, turn right full hold 2 seconds, back to the left full hold 2 seconds, center the wheel wait 5 seconds restart the car
Here is a DIY on the Steering Angle Sensor. http://www.bimmerfest.com/forums/showthread.php?t=646253
But like I said before, some claim it can only be reset through software.
 

·
Wingnut
Joined
·
4,096 Posts
as bear says, there are claims either way, both have stated success success, not having had to do this (yet), ive no active knowledge. hiya alex, long time.
 

·
Registered
Joined
·
4,028 Posts
Discussion Starter #4 (Edited)
There is still some debate on this: via software or manual calibration. Let us know...

Here is a DIY on the Steering Angle Sensor. http://www.bimmerfest.com/forums/showthread.php?t=646253
But like I said before, some claim it can only be reset through software.
Angrybear your user name should be Nicebear:thumbup: And, thanks for the link, but hope I don't ever have to use it.

as bear says, there are claims either way, both have stated success success, not having had to do this (yet), ive no active knowledge. hiya alex, long time.
Hi there Matt! Thanks for asking! :thumbup:

Anyway, let me reiterate myself. I think the reason it threw traction control light is due to the difference in DC voltage from the time I disconnect the battery and 45 days later.

I think this issue will eventually goes away once the DC voltages are back to normal. I hope!:) Otherwise I may have an issue with the Yaw sensor.

I was able to use my C110 to read live data on the wheel speed sensors momentary then the frame just freezed. WTF!!! Well! Maybe because I only paid 60 bucks and that is what I've got for Chinese knock off.:)

At any rate, I was able to erase the codes. BTW, the code was "Steering Angle..."

I may try to do a manual calibration if it comes back.

Thanks for chime in guys.
 

·
Nothing to read here...
Joined
·
2,694 Posts
Either the manual or software version work. As tab said come to a stop and turn the steering wheel full left or full right and drive straight. It should clear. Though not that if your alignment is off and your steering wheel is off center by more than 5 degrees when driving you will trigger the code again. Don't ask how I know

By software use pasoft or any really , dis/gt1, tool32 from the ediabas package or inpa(you'll need to source the correct version of inpa that has the steering angle test)
 

·
Registered
Joined
·
4,028 Posts
Discussion Starter #7 (Edited)
Angrybear, you're just a teddy bear!:)

Anyway thanks for the manual calibration guys. But, I'm going to hold out on it. Like I said I was able to erased the code, the light is still out after a few runs so far so good. Time will tell.
 

·
Wingnut
Joined
·
4,096 Posts
sure is easy to tell on here who has young children...lol
 

·
Registered
Joined
·
4,028 Posts
Discussion Starter #9
Update

I'm going to say no calibration necessary in my case. I've been running around all day and the traction light is still off.

All I can speculate is the electrical system is back to where it was before, so the yaw rate sensor is happy with what it sees.
 

·
Wingnut
Joined
·
4,096 Posts
i cant say that ive ever seen or heard of the yaw rate sensor going bad
 

·
Registered
Joined
·
4,028 Posts
Discussion Starter #11
It's back but with update

OK guys. So, after haven't started the car for 2 weeks first start up the DSC light came on and greeted me. :(

Using my C110 I cleared all the codes in ABS and LEWD menus. Here are the codes.
Steering angle sensor in ABS menu.
Steering slider in LEWD menu.
But, as soon as I drive away DSC light comes right back.

OK you SOB piece of ****. I performed the manual steering calibration by turning the steering clockwise and counter clockwise lock to lock, didn't do a thing no help whatsoever. The DSC light comes right back with a vengeance.

Read the codes again and this time not only slider but also has another code in the LEWD menu which was slider power supply. Ok, so I figured I've lost supply power to the steering angle.

I tried to clear the codes again but this time the DSC will not turn OFF. Hum!
The next thing I did was moving the steering wheel telescopic column all the way to the its reset position which is closer to the instrument panel or away from the driver. And, by doing this I was able to clear the DSC light.

I went for a drive, slowly I put the steering wheel telescopic to the middle and so far so good.

My conclusion is I have a bad connection in the steering angle sensor. I need to take this up sometime in the spring, unless it happens again.
 

·
Registered
Joined
·
1,151 Posts
Either the manual or software version work. As tab said come to a stop and turn the steering wheel full left or full right and drive straight. It should clear. Though not that if your alignment is off and your steering wheel is off center by more than 5 degrees when driving you will trigger the code again. Don't ask how I know

By software use pasoft or any really , dis/gt1, tool32 from the ediabas package or inpa(you'll need to source the correct version of inpa that has the steering angle test)
Want to thank Barracuz for the manual reset procedure. My DSC light came on the other day on my '01 540i 6 speed, after playing with PASoft, checking & clearing errors. I'm not sure if I "reset" anything on PASoft or not. I did the reset as mentioned, 'full turn to left, then full turn to right, then full turn to left again, then to center & drove straight. My center 'triangle & circle" light has not come back on after 3-4 days of short trips. Hope this fixed it. How simple can it get.
Some times it's good to let others know what works & what doesn't.
Thanks to the forum!!
 

·
Learning Every Day
Joined
·
684 Posts
Was just able to use the manual method to clear my "BRAKE" and "ABS" lights on my dash - thank you!!!

Now to the MID light on the dash... I'm so unsure how to use scan tools and a laptop I bought just to be able to work on this car.... :-(
 

·
Registered
Joined
·
4,028 Posts
Discussion Starter #14
What! You guys are lucky. In my case it's the steering angle sensor.
 

·
Nothing to read here...
Joined
·
2,694 Posts
Mines still throwing codea xD. And I got inspections coming up in a month xD.

Anyone know how to disable abs codes? xD and while we are at it how about the srs codes too! xD

I could do it but can't be bothered to be in a horrible position for an hour changing the stupid thing.
 
1 - 15 of 15 Posts
Top