Bimmerfest BMW banner

981 - 1000 of 1018 Posts

·
Registered
Joined
·
49 Posts
...but my iPhone still stubbornly refuses to let me see text messages. And the other thing is that I'm unable to get Mirrorlink working with the Android phone. On the phone the mirrorlink seems to be USB only but when I plug the USB in then the car says "Unrecognised USB device" or something like that although it sees the phone in the sources list fine just not for mirrorlink.
FURTHER UPDATE - OK so I found that you have to change a setting on the phone itself in the Bluetooth config. And now I can see text messages in iDrive for my iPhone. It will also read them out, in typical computer voice fashion. However there is no option to reply or send (which I think there was before??)...one step forward, one back! At one point it said something about sending text messages from the car is not supported by my phone but that's rubbish as I used to send messages with the same phone in a £15k Peugeot (via the car system I mean obviously). Anyone got any answers on this please? Also the mirrorlink issue remains unsolved though I've given up on that for now. (when I say mirrorlink I could well mean miracast, whatever it called it in the car)
 

·
Registered
Joined
·
10 Posts
Also the mirrorlink issue remains unsolved though I've given up on that for now. (when I say mirrorlink I could well mean miracast, whatever it called it in the car)
Hi, Mirrorlink is hit and miss, I tried it with several phones. Worked: Samsung Galaxy S8, Huawei P30, Huawei nova, Lg G Pad VK815. Did not work: Sony XZ2 Premium, Nexus 6P. BTW Wifi antenna is needed if not present.
 

·
Registered
Joined
·
49 Posts
Hi, Mirrorlink is hit and miss, I tried it with several phones. Worked: Samsung Galaxy S8, Huawei P30, Huawei nova, Lg G Pad VK815. Did not work: Sony XZ2 Premium, Nexus 6P. BTW Wifi antenna is needed if not present.
It's a Samsung Galaxy A40 that I tried without success. Interesting you got a Galaxy S8 to work. Was that plugged in with USB or not? Did you connect via Bluetooth first or connect straight to Mirrorlink? My A40 only seems able via USB, in the settings you can't switch the Mirrorlink on without USB, but then the car says USB device not recognised. It will connect via Bluetooth for calls etc
Must have a wifi antenna already because Carplay connects using wifi so that can't be the problem.
 

·
Registered
Joined
·
10 Posts
It's a Samsung Galaxy A40 that I tried without success. Interesting you got a Galaxy S8 to work. Was that plugged in with USB or not? Did you connect via Bluetooth first or connect straight to Mirrorlink? My A40 only seems able via USB, in the settings you can't switch the Mirrorlink on without USB, but then the car says USB device not recognised. It will connect via Bluetooth for calls etc
Straight via WiFi, there is separate system app in S8 called Smart view.
 

·
Registered
Joined
·
49 Posts
Having done this coding, fairly successfully, I've discovered there is a Fault Code appearing in ISTA. It's a different code to the one mentioned earlier in the thread, about the 2nd microphone, although it could mean the same. It says...

S 8410 Functional limitation, mobile device connection

So do you think this is just the microphone that can be FDL'd out or is this related to the Wireless Charger itself? If the latter can I FDL it out in the same way?
 

·
Premium Member
Joined
·
39,674 Posts
Hi Shawn, how about for G01 that also has HU_MGU? Use 6NW as well? I already have 6NV, is it the same?
6NNW seems to be much more:

6NV Telephony with wireless charging:

"Telephony with Wireless Charging for smartphone, smartphone holder at the front, in front of the cupholders, with inductive charging for suitable mobile phones (including LED charge level indicator and mobile phone reminder alert). For selected smartphones without an inductive charging function, special charging cases are available via Genuine BMW Accessories.
Other functions include:
- Improved hands-free capability for front passenger by provision of a second microphone.
- 2 x USB connections with 2.1A charging current for shorter charging times of smartphones and tablets.
- At any given time, 2 mobile phones and one audio player can be paired via Bluetooth."

6NW Telephony with wireless charging:
- Improved handsfree capability for passenger by a second microphone
- 2 USB ports with 2.1A charging current for shorter charging times of smartphones and tablets
- Bluetooth / Wi-Fi Audio Streamin
- Wi-Fi hotspot (6WD) enables the connection of mobile devices to the Internet via the built-in car SIM card. Depending on the local LTE availability, up to 10 devices with max. 100 Mbit / s surf the Internet. The use is chargeable and is carried out directly in the vehicle with the appropriate mobile carrier
- Compressed video over USB interface playable
- 2 phones and an audio player coupled simultaneously via Bluetooth
- Representation of PIM content from the Customer Service on the Control Display in the menu or Office Communications
- Display of contact photos from the address of the customer phone on the Control Display
- Display of album art
- Software update for multimedia and telephony via USB interface
 

·
Premium Member
Joined
·
39,674 Posts
Having done this coding, fairly successfully, I've discovered there is a Fault Code appearing in ISTA. It's a different code to the one mentioned earlier in the thread, about the 2nd microphone, although it could mean the same. It says...

S 8410 Functional limitation, mobile device connection

So do you think this is just the microphone that can be FDL'd out or is this related to the Wireless Charger itself? If the latter can I FDL it out in the same way?
Try this:

FDL Code the following and clear fault codes afterwards with E-Sys Transmitter:

HU_NBT > MICROPHONE_NUMBER = wert_01
HU_NBT > WLAN_DIAGNOSE = nicht_aktiv

Clear Fault Codes with E-Sys:

Click "External Applications" in the left menu.
Click "External Application"
Double-click "Transmitter"
Scroll to the bottom and click "14 FF FF FF,31 01 0F 06,31 01 40 00 00,31 01 40 00 05,31 01 40 00 01;Clear all DTCs (clear DTC,clear Infospeicher,ZFS – DM_Lock,clear ZFS – DM_Clear,ZFS – DM_Unlock)"
Click Connect
Click Send
 

·
Registered
Joined
·
49 Posts
Try this:

FDL Code the following and clear fault codes afterwards with E-Sys Transmitter:

HU_NBT > MICROPHONE_NUMBER = wert_01
HU_NBT > WLAN_DIAGNOSE = nicht_aktiv

Clear Fault Codes with E-Sys:

Click "External Applications" in the left menu.
Click "External Application"
Double-click "Transmitter"
Scroll to the bottom and click "14 FF FF FF,31 01 0F 06,31 01 40 00 00,31 01 40 00 05,31 01 40 00 01;Clear all DTCs (clear DTC,clear Infospeicher,ZFS – DM_Lock,clear ZFS – DM_Clear,ZFS – DM_Unlock)"
Click Connect
Click Send
Thank you Shawn, really appreciated.
I presume where you put HU_NBT I change to HU_MGU (G20), and I will give it a go soon, when I get EsysX which I think I need for FDL coding. The bottom part of your instructions about the Transmitter, is this just to clear the fault code? I could possibly do that easier from ISTA+?
 

·
Premium Member
Joined
·
39,674 Posts
Thank you Shawn, really appreciated.
I presume where you put HU_NBT I change to HU_MGU (G20), and I will give it a go soon, when I get EsysX which I think I need for FDL coding. The bottom part of your instructions about the Transmitter, is this just to clear the fault code? I could possibly do that easier from ISTA+?
Yes, MGU in your case.

ISTA would not be any easier to clear fault code. You are already in E-Sys for FDL Coding, so Running Transmitter is as easy as it gets.
 

·
Registered
Joined
·
244 Posts
Hi Shawn, how about for G01 that also has HU_MGU? Use 6NW as well? I already have 6NV, is it the same?
6NNW seems to be much more:

6NV Telephony with wireless charging:

"Telephony with Wireless Charging for smartphone, smartphone holder at the front, in front of the cupholders, with inductive charging for suitable mobile phones (including LED charge level indicator and mobile phone reminder alert). For selected smartphones without an inductive charging function, special charging cases are available via Genuine BMW Accessories.
Other functions include:
- Improved hands-free capability for front passenger by provision of a second microphone.
- 2 x USB connections with 2.1A charging current for shorter charging times of smartphones and tablets.
- At any given time, 2 mobile phones and one audio player can be paired via Bluetooth."

6NW Telephony with wireless charging:
- Improved handsfree capability for passenger by a second microphone
- 2 USB ports with 2.1A charging current for shorter charging times of smartphones and tablets
- Bluetooth / Wi-Fi Audio Streamin
- Wi-Fi hotspot (6WD) enables the connection of mobile devices to the Internet via the built-in car SIM card. Depending on the local LTE availability, up to 10 devices with max. 100 Mbit / s surf the Internet. The use is chargeable and is carried out directly in the vehicle with the appropriate mobile carrier
- Compressed video over USB interface playable
- 2 phones and an audio player coupled simultaneously via Bluetooth
- Representation of PIM content from the Customer Service on the Control Display in the menu or Office Communications
- Display of contact photos from the address of the customer phone on the Control Display
- Display of album art
- Software update for multimedia and telephony via USB interface
Thanks Shawn!
 

·
Registered
Joined
·
49 Posts
Try this:

FDL Code the following and clear fault codes afterwards with E-Sys Transmitter:

HU_NBT > MICROPHONE_NUMBER = wert_01
HU_NBT > WLAN_DIAGNOSE = nicht_aktiv
Hi Shawn, I had problems with this.

When I searched in EsysX I found the WLAN_DIAGNOSE straight away and changed it to nicht_aktiv. The MICROPHONE_NUMBER wasn't present but there was MICROPHONE_QUANTITY instead which seemed to be the same thing. But the werte value was set to Werte=07, ie not 2. At that point I was a bit cautious whether to change it to 01 or not so left it. I just FDL coded the WLAN_DIAGNOSE.

I then had to go somewhere and when I got back realised that my Apple Carplay wasn't working AT ALL. I disconnected and reconnected the phone but it didn't help. So I set the WLAN_DIAGNOSE back again. While in ESysX I thought I'd try the MICROPHONE_QUANTITY this time (else I thought I've changed nothing so will probably still get the Fault Code)...so I changed the wert value to 01 and FDL coded both those changes.

So my Carplay started working again, and I was able to breathe slightly easier, but now I discovered the microphone wasn't working AT ALL.

So I thought I'd experiment and I changed the other setting in MICROPHONE_QUANTITY, Ausgelesen. Before I started I noted that it had been set to cf_2mic_6ref. Changing the wert value to 01 previously had changed it but this time I changed it to cf_1mic_6ref (which automatically changed the werte value to 06) and FDL coded.

So now my microphone seems to be working again.

Does what I have done sound OK to you? I've attached a couple of screenshots so you can see the other options.

I don't know if this has solved the Fault Code problem yet, I'll have a look tomorrow, had too much drama today already.
 

Attachments

·
Premium Member
Joined
·
39,674 Posts
...So I thought I'd experiment and I changed the other setting in MICROPHONE_QUANTITY, Ausgelesen. Before I started I noted that it had been set to cf_2mic_6ref. Changing the wert value to 01 previously had changed it but this time I changed it to cf_1mic_6ref (which automatically changed the werte value to 06) and FDL coded.

So now my microphone seems to be working again.

Does what I have done sound OK to you? I've attached a couple of screenshots so you can see the other options.

I don't know if this has solved the Fault Code problem yet, I'll have a look tomorrow, had too much drama today already.
I don't know why you lost CarPlay, but WLAN_DIAGNOSE activates the WLAN antenna impedance check. It is NOT required for CarPlay to function.

MICROPHONE_QUANTITY = cf_1mic_6ref (Werte = 06) should be correct. Error for "Microphone 2 Line Disconnection" should be gone.
 

·
Registered
Joined
·
49 Posts
I don't know why you lost CarPlay, but WLAN_DIAGNOSE activates the WLAN antenna impedance check. It is NOT required for CarPlay to function.
Perhaps they increased the scope of its function in the G20's? I know Carplay uses wifi and it definitely wouldn't work when that was deactivated and started working again when I reactivated it. Though for a while after it seemed to be a bit "flaky", saying the internet connection was not available etc intermittently. Hope it's gonna fix itself on that.

MICROPHONE_QUANTITY = cf_1mic_6ref (Werte = 06) should be correct. Error for "Microphone 2 Line Disconnection" should be gone.
Oh good thanks. The error was "S 8410 Functional limitation, mobile device connection" so I don't know if that's the same problem. I'll check tomorrow.

Thanks for your help.
 

·
Premium Member
Joined
·
39,674 Posts
Perhaps they increased the scope of its function in the G20's? I know Carplay uses wifi and it definitely wouldn't work when that was deactivated and started working again when I reactivated it. Though for a while after it seemed to be a bit "flaky", saying the internet connection was not available etc intermittently. Hope it's gonna fix itself on that.

Oh good thanks. The error was "S 8410 Functional limitation, mobile device connection" so I don't know if that's the same problem. I'll check tomorrow.

Thanks for your help.
I don't know what you have going on, but WLAN_DIAGNOSE functionality has not changed for G20.
 

·
Registered
Joined
·
2 Posts
Hello everyone,

I***8217;m new here and thank you in advance for your help.
I have a f30 318d bmw 2014, and it seems that it doesn***8217;t have bluetooth enhanced.
That***8217;s why I***8217;d like to change 6NH to 6NS.
I have read quite a lot about coding and I***8217;m confused now with VO coding and FDL coding. Which one is safier for coding ?
I alteady ordered a enet to ethernet cable on amazon (link bellow) It comes with 5 CDs (e-sys 3.23.4, V50.3)

https://www.amazon.fr/gp/aw/d/B07SJHLS5S/ref=psdcmw_2430202031_t1_B07LGC6MH5

I would like to know if it is enough for this coding or do I need newer software or else.
I***8217;ve never coded so far.

Thanks
 

·
Registered
Joined
·
49 Posts
Oh, beats me then. Hopefully the microphone fix will cure the fault code.
FDL coding the microphone quantity has not solved the Fault code I'm getting:

S 8410 Functional limitation, mobile device connection

Do you have any other suggestion of what to code to solve it apart from the WLAN_DIAGNOSE, as I don't want to lose my Carplay?
I noticed a setting just called WCA, set to aktiv, would that be relevant?
 

·
Premium Member
Joined
·
39,674 Posts
FDL coding the microphone quantity has not solved the Fault code I'm getting:

S 8410 Functional limitation, mobile device connection

Do you have any other suggestion of what to code to solve it apart from the WLAN_DIAGNOSE, as I don't want to lose my Carplay?
I noticed a setting just called WCA, set to aktiv, would that be relevant?
No idea. I have never seen "S 8410 Functional limitation, mobile device connection" before.

The usual fault code is "0xB7F850 - Microphone 2 Line Disconnection"
 
981 - 1000 of 1018 Posts
Top