BimmerFest BMW Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello :D

I'm trying to understand some stuff, so this is going down as a R&D topic.

I've got a HU_Entry (2014) off a F10, I want to read and edit the FDL via esys using the Quadlock Eth connection. The issue is that my headunit is sending ARP frames (Wireshark logs) and I can see it's IP, but it doesn't ping. Esys throws errors and after activating an FA with units VIN, still no ECU read. FSC Status read returns 0 ecu(s).

Tested with local dhcp server and 169.254.199.98 and 99-gw.
Tested with router

Same setup used for NBT and it worked wonderful.

The packets sent to it for wakeup:
0x130 - 0x45, 0x40, 0x22, 0x8F, 0xFE
0x12F - 0x37, 0x7C, 0x8A, 0xDD, 0xD4, 0x05, 0x33, 0x06
0x563 - 0x00, 0x00, 0x00, 0x00, 0xFF, 0xFF, 0x00, 0x63

All those sent via CAN at 500kbps (As i saw it wakes up even at 100kbps...)
(No zgw,cas, etc...)

Any ideas? :D
 

Attachments

1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top