BimmerFest BMW Forum banner
1 - 20 of 20 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter · #1 ·
Hello all.
Im having serious problems with my 1998 540i 155k

1st, trans fail/safe car is stuck in 3rd or 4th gear. when I go from park to reverse or drive it has a huge jerk.

2nd, i have to turn key over twice before it will start. first time all i get is a dead feeling. once i turn key all the way off and back on then it fires right up.

3rd, when car is in drive the dash says im in park and vice versa. when im in park it says im in drive.

4th, remote key doesnt work anymore. I tried reprogramming and nothing.

5th, lost job so cant afford dealership fees, my friend offered to buy the car from me for 3000, that is only because he knows i paid 3500 just for the rims last year.

Any help would be greatly appreciated. preferably any cheap do it yourself fixes that might work or would be happy with any advice from someone who has had the same problems before.
 

Attachments

·
Registered
Joined
·
6,962 Posts
+1, the multiple electrical failures combined with the simultaneous Trans Prog Failsafe warning suggests a problem in your electrical system rather than your tranny. Recommend you run the battery test using the OBC to determine if your battery is providing sufficient voltage. The alternator is the second thing to look at. I think AutoZone can test your alternator for you.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #5 ·
Ok, I have an appointment for a dianostic test tomorrow. Then after I get the results i'll go by autozone and get a battery and alternator test. I'll post what the results were and the codes that pulled up. So no one thinks I should sell the car for 3500?
 

·
Registered
Joined
·
6,962 Posts
Not yet. The car may have a relatively simple fix (replace battery and/or alternator). Until you determine the root cause of the problem, you cannot determine the corrective action (to fix or dump the car).
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #7 ·
ok, diagnostic come back today. Here are the codes,
engine 139, 062, 050, 052, 055
transmission 112, 59, 082, 060

The shop i took it to supposely specilizes in BMW's but they say I have to take this to the dealer because they cannot program the computer. They charged me 170.00 for nothing. So now I have to take it the the dealership and they gonna charge me a diagnostic fee again. They think its the mode selector switch. Has any one experienced anything like this? I know the engines codes are for cylinder misfires. Please advise on what I should do, I dont have a job right now should I just sell it?
 

·
Registered
Joined
·
6,962 Posts
ok, diagnostic come back today. Here are the codes,
engine 139, 062, 050, 052, 055
transmission 112, 59, 082, 060

The shop i took it to supposely specilizes in BMW's but they say I have to take this to the dealer because they cannot program the computer. They charged me 170.00 for nothing. So now I have to take it the the dealership and they gonna charge me a diagnostic fee again. They think its the mode selector switch. Has any one experienced anything like this? I know the engines codes are for cylinder misfires. Please advise on what I should do, I dont have a job right now should I just sell it?
These guys ripped you off. You could have bought a code reader (maybe two) for that much. I once had the Trans Prog Failsafe on my previous e39 and the dealer wanted to replace the tranny. I refused and had them reset the computer. It never happened again for 30K until the car was totaled. I believe mine was caused by a bad sensor. Try the battery first.
 

·
Registered
Joined
·
6,962 Posts
If you still have the Trans Prog Failsafe message then the dealer has to reset it (for $130 or so). GT-1 is about $1,000 and is what the dealer uses.
Not sure I understand what Propellerhead's post means. There are many other BMW software packages out there. However, I am unaware any of the others can reset the tranny. Maybe he has one that will do it.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #16 ·
Cant figure out whats wrong. I put new battery in and it still says bad battery. Something is seriously wrong with the computer/electronics on this car. I cant program my key, garage door remote, or figure out the failsafe problem. I have to take it to the dealer and see what the bad news is.
 

·
Registered
Joined
·
6,962 Posts
While this may be true, stealers do not rebuild trannys or other systems. They simply replace them. And their diagnoses are often WRONG! Did they charge you for that diagnosis? If yes, have them reset the tranny and take the car. If you are lucky, this was a one time occurance (it was for me). It's a low/no cost risk with high potential payback.
 

·
Registered
Joined
·
91 Posts
I had the same problem with my car a few months after replacing the reverse drum in my tranny. The gearbox guys said it was the shift sensor/switch thingy which cost more than the reverse drum, etc. My key also stopped operating the central locking and my gear indicator on the dash did not correspond to the gear the car was in. on cold start, the car would go into safe mode but after driving as little as 3-5km and switching off and then turning the car on again, everything was perfect. no failsafe.
I replaced my battery and all was well. no more cold start failsafe. I reprogrammed my keys and door locks, windows,etc work fine.
Until the reverse drum failed again, that is.
FYI, I replaced my battery with a Bosch equivalent.
 

·
Registered
Joined
·
68 Posts
Discussion Starter · #20 ·
Yes I have had the tranny reset 3 times and the 082 code comes right back up. I replaced the battery 3 days with an 1150 cold cranking amp optima. As for the reverse drum, ill have to look into that because I don't really no what that is. I think I'm leaking transmission fluid, so I'm gonna have that replaced and hopefully sealed. Has anyone ever done this themselves?
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top