BimmerFest BMW Forum banner
1 - 20 of 28 Posts

· Registered
Joined
·
125 Posts
Has INPA ever worked on this car? I'd be more concerned that your install doesn't work. If it did used to work then I'd be looking at the ZGM. If you can't speak to any module in the car then that's the 1 module that could cause that as all communication goes through it for diagnostics.

For the cost of it (think I paid £12) I'd just get another ZGM for testing. If that still fails and your INPA does work - test it on other cars - then I'd be thinking there must be a wiring issue somewhere...

What are the symptoms other than a lack of diagnostics? Why did you send off the DME/CAS?
 

· Premium Member
2006 BMW 750li e66
Joined
·
30 Posts
Discussion Starter · #3 ·
Has INPA ever worked on this car? I'd be more concerned that your install doesn't work. If it did used to work then I'd be looking at the ZGM. If you can't speak to any module in the car then that's the 1 module that could cause that as all communication goes through it for diagnostics.

For the cost of it (think I paid £12) I'd just get another ZGM for testing. If that still fails and your INPA does work - test it on other cars - then I'd be thinking there must be a wiring issue somewhere...

What are the symptoms other than a lack of diagnostics? Why did you send off the DME/CAS?
can you tell me where to get another zgm i cant seem to find any here is my zusb and yes the ista and inpa worked on another vehicle
i attached images of all my zusb the zgm part number 9314363
Font Parallel Pattern Number Rectangle

Font Material property Pattern Parallel Rectangle
Font Parallel Pattern Number Rectangle
Font Material property Pattern Parallel Rectangle
 

· Registered
Joined
·
125 Posts
Well that's odd because that does appear to be communicating with all modules...

If you try connecting to the ZGM on INPA (sorry can't remember what section it's under) does that work? I've found that for some reason my car will refuse to communicate sometimes until I connect to the ZGM then it will work? Don't know if this is an issue with my car but might be worth a try.

Also INPA might call it a SGM or the central gateway module. The terms seem to get used interchangeably.
 

· Premium Member
2006 BMW 750li e66
Joined
·
30 Posts
Discussion Starter · #5 ·
Yes
Has INPA ever worked on this car? I'd be more concerned that your install doesn't work. If it did used to work then I'd be looking at the ZGM. If you can't speak to any module in the car then that's the 1 module that could cause that as all communication goes through it for diagnostics.

For the cost of it (think I paid £12) I'd just get another ZGM for testing. If that still fails and your INPA does work - test it on other cars - then I'd be thinking there must be a wiring issue somewhere...

What are the symptoms other than a lack of diagnostics? Why did you send off the DME/CAS?
also
I sent the DME off to have it tested because I have been having intermittent issues with the electrical and just want to diagnose and repair the issue correctly. Also do you know if the B+ positivle jumper terminal may be an issue I read that it give power to dme and other things as well. I will be replacing it as well when I remove it and get the part number tomorrow. Waiting on diagnosis of dme and they will be creating me a second key fob as well and testing the cas dme I sent the FOB DME and CAS.
I just cant seem to find the ZFB anywhere I tried searching google.
 

· Premium Member
2006 BMW 750li e66
Joined
·
30 Posts
Discussion Starter · #6 ·
Well that's odd because that does appear to be communicating with all modules...

If you try connecting to the ZGM on INPA (sorry can't remember what section it's under) does that work? I've found that for some reason my car will refuse to communicate sometimes until I connect to the ZGM then it will work? Don't know if this is an issue with my car but might be worth a try.

Also INPA might call it a SGM or the central gateway module. The terms seem to get used interchangeably.
The screen shots are saved from the past
Can you tell me how to find that module on ebay or somewhere? with the same part number and where I can find it I went into the glove box and only found the airbag module behind fuse box
 

· Registered
Joined
·
125 Posts
When I replaced mine I just searched for 'e65 gateway module' on eBay and bought the cheapest one! Feel free to correct me anyone but I think they're interchangable so it shouldn't matter which one you get? I didn't even bother programming the VIN into mine or synchronising the airbag system timer thing and it just worked plug and play.


Something like that? Don't know what breakers are like in the States but odd obscure parts like these tend to be really cheap because nobody wants them.
 

· Premium Member
2006 BMW 750li e66
Joined
·
30 Posts
Discussion Starter · #8 ·
When I replaced mine I just searched for 'e65 gateway module' on eBay and bought the cheapest one! Feel free to correct me anyone but I think they're interchangable so it shouldn't matter which one you get? I didn't even bother programming the VIN into mine or synchronising the airbag system timer thing and it just worked plug and play.


Something like that? Don't know what breakers are like in the States but odd obscure parts like these tend to be really cheap because nobody wants them.
so it is the airbag module behind glovebox I thought it was just airbag module but I guess the ZGM is built into it and the car will not communicate with this being an issue?
So I can replace it with any from the e65 e66 range?
 

· Registered
Joined
·
125 Posts
Yeah it's not the module with the 600 different fiber optic connections, it's directly above that one. When you connect to the diagnostics with INPA/ISTA etc... Everything the car says to you and everything you say to the car goes through this module. It's connected to the byteflight, the K-CAN, and the PT-CAN.

To be safe I'd just make sure that you get one from a facelift to match your car.
 

· Premium Member
2006 BMW 750li e66
Joined
·
30 Posts
Discussion Starter · #11 ·
Yeah it's not the module with the 600 different fiber optic connections, it's directly above that one. When you connect to the diagnostics with INPA/ISTA etc... Everything the car says to you and everything you say to the car goes through this module. It's connected to the byteflight, the K-CAN, and the PT-CAN.

To be safe I'd just make sure that you get one from a facelift to match your car.
well I will be replacing that and the B+ jumper box ordering both tomorrow just to make sure going to remove both.
So this module with the fiber optics doesnt need to be aligned
 

· Premium Member
2006 BMW 750li e66
Joined
·
30 Posts
Discussion Starter · #13 ·
07-08 BMW 750Li 750i E66 ECU SGM 18 Airbag Control Gateway Module 9149934 OEM
that isnt far off from my sgm sim module which is 9149936 you think i should order it>
 

· Registered
Joined
·
125 Posts
Oh actually they might have combined the ZGM and the SIM in the facelift and mines a prefacelift so this is where my knowledge runs out. Anyone else?

Check realoem.com to see what modules it shows behind the glovebox for your vin.

I didn't have to program mine but I've heard of other people having to in order to knock off the airbag light.
 

· Registered
Joined
·
125 Posts
Just had a look at realoem and it still lists a gateway module like the first one I posted for the facelift cars. Are you sure there isn't another module sitting directly above that other one you posted behind the glovebox?

It should just have the one yellow fiber optic plug and one normal blue/black electrical plug. If it does have that then it's that module you want not the other one.

Again though I'm no expert as I've only ever seen the one e65 and it's my prefacelift 2003 and it's right hand drive so module locations might even be different to yours too.
 

· Premium Member
2006 BMW 750li e66
Joined
·
30 Posts
Discussion Starter · #20 ·
Just had a look at realoem and it still lists a gateway module like the first one I posted for the facelift cars. Are you sure there isn't another module sitting directly above that other one you posted behind the glovebox?

It should just have the one yellow fiber optic plug and one normal blue/black electrical plug. If it does have that then it's that module you want not the other one.

Again though I'm no expert as I've only ever seen the one e65 and it's my prefacelift 2003 and it's right hand drive so module locations might even be different to yours too.
Here is a photo behind gloveboxi
Bicycle Crankset Wheel Bicycles--Equipment and supplies Bicycle tire
 

Attachments

1 - 20 of 28 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top