BimmerFest BMW Forum banner
1 - 6 of 6 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 2001 330i that installed a new Ice>Link Plus in about two weeks ago with no problems at all. The interface with the proclip mount is by far the best option for a factory installed mount. The unit has worked flawlessly until just the other day when Dension released a firmware upgrade. I performed the upgrade as directed (mostly because I have an iPod Photo and wanted the menu fix) but as soon as the update installed the Ice>Link became non-functional. I am no longer able to select the cd-changer on my radio and the iPod does not charge in the base. I have emailed Tom and Dension support over the past few days with no reply and left a voicemail with tech support.

If anyone else that has upgraded to version 2.06 had success, a solution to the problem or are in the same situation as me, let me know. I'm going crazy with no one to help! :mad:
 

· Registered
Joined
·
76 Posts
NoNameEMT said:
If anyone else that has upgraded to version 2.06 had success, a solution to the problem or are in the same situation as me, let me know. I'm going crazy with no one to help! :mad:
Yikes....my IceLink was installed last weekend, had v2.06, and is working great...I had a different question for Tom, and it did take a couple days for him to get back to me, but he did...hopefully he'll be able to help you.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Follow up: Received an email this afternoon from Dension USA Support as follows:

"Hi

You can try restting your IceLink, unplug the battery for a few minutes.
If it doesn't help send the IceLink in for repair.
Best Regards,

Zoltan | Dension USA, Inc.
Tech Support
Ph. 866.822.3673
Fx. 562.684.4010"

So the two week old unit is back on another cross country trip by priority mail, hopefully to have a quick turn around.
 

· Registered
Joined
·
351 Posts
It depends on where the message is left, if you do not contact me directly - I unfortunately cannot anwser directly.

Using the Bimmerfest PM feature, my email ([email protected]) or 562.595.5153 x115 are three guaranteed ways to reach me directly during business hours.
 

· Registered
Joined
·
351 Posts
NoNameEMT said:
Well none the less the unit is on its way for repair. Will it come back with version 2.06 already installed? What is the normal turn around time for repair? --Brian Prince
As soon as we received the return, it will be updated and sent back immediately. The entire process takes about 10 minutes.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top