BimmerFest BMW Forum banner

1 - 19 of 19 Posts

·
Cutter of animals
Joined
·
66 Posts
Discussion Starter #1
Hello,
I just got back home from a drive and turned off the car. The screen on the iDrive still showed the map even after turning it off. So...I waited for a few seconds, even locked the doors, but it still wouldn't turn off. I got back in, turned it on, waited a few seconds and turned it off again. Still on. Then I walked away for a few minutes hoping it would do the trick. Come back, and now its white with about 6 vertical gray bars. It's stuck at that screen and won't go away. The car starts and stops normally, nothing wrong there. But how do I turn the damn screen off??? I'm gonna have a dead battery eventually if it doesn't turn off.
Any ideas?
 

·
Boosted Bavarian
Joined
·
1,272 Posts
Very strange. I wouldn’t think the unit should be getting any power at all with the ignition fully off. A battery disconnect/reset may be in order before it drains it.
 

·
Cutter of animals
Joined
·
66 Posts
Discussion Starter #3
So I left the damn thing alone overnight with the screen still on, expecting it to be dead today. But...when I got in, the screen was off and the engine started and the iDrive booted up like nothing ever happened. Very odd.
Looks like another trip to the dealer is in order. I've lost count of how many that makes...

Looks like I'm selling before the original warranty expires. Since the iDrive isn't covered in the extended 2 years I would imagine any repairs would be a nice chunk of change. Sad cause I love this car. S4 anyone...?
 

·
Cutter of animals
Joined
·
66 Posts
Discussion Starter #4
So I have to wait until the 28th to take it in if I want a loaner car. Or I can pay for a rental (which they used to provide for free). Wtf is that??? I pay 40k for a car, which has a serious (possibly safety) issue covered under warranty and I have to fork out more money just to go home and get to work the next day?

What do people do who get in a real accident or the damn thing breaks down? Buy another car??? This is ridiculous.

Hopefully this doesn't become a safety issue and it won't be a problem until then. Quite disappointed in BMW...

Is Audi better about this ****?
 

·
about the mini part....
Joined
·
1,085 Posts
It should shut off once you hold the start/stop button for a few seconds. Even if it doesn't it will shut off in 15 mins or so. But still, this seems strange.
 

·
Registered
Joined
·
1,276 Posts
If you have comfort access, you need to hit the start/stop button twice or else various items stay on until the car goes to sleep in about 15 minutes.
 

·
Cutter of animals
Joined
·
66 Posts
Discussion Starter #7
If you have comfort access, you need to hit the start/stop button twice or else various items stay on until the car goes to sleep in about 15 minutes.
Hahahaha. You think I'm an idiot? The screen didn't stay on the way it normally would if I did as you described (I've had the car for a year and a half, and figured that out within a couple hours of having it). That's the whole point. It went completely white with vertical gray bars in the middle. Turning it back on and driving for a few minutes wouldn't change the screen, nor did resetting it (pressing and holding volume knob and eject buttons). I left it alone for an hour before giving up. But, alas, it fixed itself sometime overnight. Never happened before, and hasn't happened since.

Yet another trip to the dealer...
 

·
Registered
Joined
·
6,006 Posts
If you have comfort access, you need to hit the start/stop button twice or else various items stay on until the car goes to sleep in about 15 minutes.
Advice like this cost me a new battery (sorry, was install by warranty). I park at work and try someone advice (regarding sleep after 15 min) close my car and when to work. At lunch time get to the car - dead. Have to tow away to local dealer and change battery.
 

·
Registered
Joined
·
68 Posts
Hahahaha. You think I'm an idiot? The screen didn't stay on the way it normally would if I did as you described (I've had the car for a year and a half, and figured that out within a couple hours of having it). That's the whole point. It went completely white with vertical gray bars in the middle. Turning it back on and driving for a few minutes wouldn't change the screen, nor did resetting it (pressing and holding volume knob and eject buttons). I left it alone for an hour before giving up. But, alas, it fixed itself sometime overnight. Never happened before, and hasn't happened since.

Yet another trip to the dealer...
I had the EXACT same thing happen. It was after a service at 49,000, and for whatever reason, they had to reset the Nav during service, and I thought they were related. In any event, I checked after an hour and it had gone dark. Started fine. Fingers cross.
 

·
Registered
Joined
·
1,276 Posts
Hahahaha. You think I'm an idiot? The screen didn't stay on the way it normally would if I did as you described (I've had the car for a year and a half, and figured that out within a couple hours of having it). That's the whole point. It went completely white with vertical gray bars in the middle. Turning it back on and driving for a few minutes wouldn't change the screen, nor did resetting it (pressing and holding volume knob and eject buttons). I left it alone for an hour before giving up. But, alas, it fixed itself sometime overnight. Never happened before, and hasn't happened since.

Yet another trip to the dealer...
And how are we to know if you do or don't have CA? And who said your an idiot? BTW, if the screen is fine when you take in for service, they are not going to do anything. Idrive does weird things from time to time. My 07 did some weird stuff and my 09 idrive has new and different quirks especially when it boots up sometimes.
 

·
driving a D around RTP
Joined
·
536 Posts
It went completely white with vertical gray bars in the middle.
In a desktop/laptop computer that type of symptom usually means bug in a low level driver or bad hardware.
  • If bad hardware it could be caused by a marginal part getting too hot to operate properly. Potential for HW-level errors increases as temperature increases. Was it hot that day? Was the car running for a long time before the issue occurred?
  • If it was due to a software bug then you might get lucky and never experience this issue again.
  • If it happens regularly then probability increases that you can get it fixed under warranty. Maybe update software, maybe replace a hardware component.
For all 3 scenarios...don't sweat it and deal with it if/when it happens again. In the mean time, enjoy your nice ride.

I don't know anything about resetting idrive. If you did successfully get it to "warm boot" and that didn't clear the issue, then it seems likely that it was a hardware issue (possibly overheated) or a software bug that caused the hardware to lock up. You say it was OK the next morning. Two things probably happened overnight: the electronic components cooled to ambient temperature, and after letting the car go fully to sleep you "cold booted" it the next morning. With some computers a cold boot more fully resets the hardware to default state than a warm boot. (cold vs. warm boot is not related to temperature...it's related to the extent to which you cut power or otherwise cause the chip to reset to default state...a software-induced reboot is sometimes a warm boot)
 

·
Registered
Joined
·
3 Posts
BMW 335i - Idrive screen won't turn off.... it's a bluetooth bug

I hit the problem today where the radio (and entire IDRIVE screen) would not shut off. Waited about 30 minutes, based on other suggestions - no good. Still on. Tried the suggestion to hold volume button down for ~20 sec to reboot Idrive. No result at all there... Tried locking doors - nope, IDrive stayed on. Now I'm panicking cuz this will surely kill the battery if I leave it.... Last hope - disabled bluetooth. It worked. Finally everything shut down. Is a fix available, BMW people?
 

·
Registered
Joined
·
91 Posts
I hit the problem today where the radio (and entire IDRIVE screen) would not shut off. Waited about 30 minutes, based on other suggestions - no good. Still on. Tried the suggestion to hold volume button down for ~20 sec to reboot Idrive. No result at all there... Tried locking doors - nope, IDrive stayed on. Now I'm panicking cuz this will surely kill the battery if I leave it.... Last hope - disabled bluetooth. It worked. Finally everything shut down. Is a fix available, BMW people?
Usually the head unit stays on with a Bluetooth device connected to it to make phone calls. So if you were on a call when you shut the car off the unit will remain powered unless you switch the audio to your phone. I don't have iDrive and my car does this if I'm on a call as I'm turning the car off.

Sent with my carrier pigeon
 

·
Registered
Joined
·
3 Posts
wasn't on a call when I turned the car off. My cell phone was in the car, but no calls had been made (or taken) today from the car. Am gonna call local dealer's service dept and see if they know anything about the problem... will post back
 

·
Registered
Joined
·
91 Posts
wasn't on a call when I turned the car off. My cell phone was in the car, but no calls had been made (or taken) today from the car. Am gonna call local dealer's service dept and see if they know anything about the problem... will post back
Maybe it needs a software update then? If you weren't on a call that's a little odd, if you have an iPhone was Siri activated? That could be another thing that causes it.

Sent with my carrier pigeon
 

·
Registered
Joined
·
6,006 Posts
I hit the problem today where the radio (and entire IDRIVE screen) would not shut off. Waited about 30 minutes, based on other suggestions - no good. Still on. Tried the suggestion to hold volume button down for ~20 sec to reboot Idrive. No result at all there... Tried locking doors - nope, IDrive stayed on. Now I'm panicking cuz this will surely kill the battery if I leave it.... Last hope - disabled bluetooth. It worked. Finally everything shut down. Is a fix available, BMW people?
there are 3 buttons you need to press and hold, not just volume control.
 

·
Registered
Joined
·
3 Posts
nope - leith bmw isn't aware of a fix for the problem.... they want to hit me up for $89 to run diagnostics. btw - the problem seemed to be solid; when i disabled bluetooth from the idrive settings, everything shut down as normal when i turned off the car (2x on the start button). Re-enabled bluetooth in the idrive settings and the problem returned (radio and idrive screen would not shut off when i turned off the car). So just for laughs I rebooted my cell phone (iphone 5c) and repeated the test. problem is now gone. So -- it kinda looks like things got in a weird state there, but rebooting the phone appears to have cleared the problem.

So yeah - CAR WON'T TURN OFF?? Try rebooting your cell phone!!! :rofl:
 

·
Registered
Joined
·
91 Posts
nope - leith bmw isn't aware of a fix for the problem.... they want to hit me up for $89 to run diagnostics. btw - the problem seemed to be solid; when i disabled bluetooth from the idrive settings, everything shut down as normal when i turned off the car (2x on the start button). Re-enabled bluetooth in the idrive settings and the problem returned (radio and idrive screen would not shut off when i turned off the car). So just for laughs I rebooted my cell phone (iphone 5c) and repeated the test. problem is now gone. So -- it kinda looks like things got in a weird state there, but rebooting the phone appears to have cleared the problem.

So yeah - CAR WON'T TURN OFF?? Try rebooting your cell phone!!! :rofl:
I had a feeling you had an iPhone, the way Siri works on headunits for audio is as if it were to dial a number. If the software glitches it could make the car think you were on a "call" when you might have accidentally activated Siri. That's probably why restarting your phone fixed it

Sent with my carrier pigeon
 

·
Registered
Joined
·
31 Posts
Hello,
I just got back home from a drive and turned off the car. The screen on the iDrive still showed the map even after turning it off. So...I waited for a few seconds, even locked the doors, but it still wouldn't turn off. I got back in, turned it on, waited a few seconds and turned it off again. Still on. Then I walked away for a few minutes hoping it would do the trick. Come back, and now its white with about 6 vertical gray bars. It's stuck at that screen and won't go away. The car starts and stops normally, nothing wrong there. But how do I turn the damn screen off??? I'm gonna have a dead battery eventually if it doesn't turn off.
Any ideas?
After you turn off car (pressing stop button with foot on brake), hit the stop button again with foot off brake.
Screen will turn off.
 
1 - 19 of 19 Posts
Top