BimmerFest BMW Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
5,263 Posts
Discussion Starter · #1 ·
Got in my car this evening and my iDrive with nav was completely dark. I don't mean dim, I mean black and totally nonfunctional. It was so non-operable that the radio didn't work, the iDrive controller was totally loose and the steering wheel buttons didn't work. The only thing on the center console that did work was the HVAC controls and the manual gear shift lever. Bluetooth pairing remained, but it was impossible to make a phone call with my paired phone unless I unpaired it. The nav DVD couldn't be ejected either.

I stopped the car several times and removed the keys, all to no avail.

Four hours later, after a night out with friends, I came back to the car and all was normal.

Any clue what might have happened? I have v25.02.
 

·
Registered
Joined
·
300 Posts
I had the same problem few months ago. This happened to me three times during April 2007. Took it to the dealer and installed latest software in June. I haven't driven my E60 much since. Will find out soon whether this problem is fixed.

Got in my car this evening and my iDrive with nav was completely dark. I don't mean dim, I mean black and totally nonfunctional. It was so non-operable that the radio didn't work, the iDrive controller was totally loose and the steering wheel buttons didn't work. The only thing on the center console that did work was the HVAC controls and the manual gear shift lever. Bluetooth pairing remained, but it was impossible to make a phone call with my paired phone unless I unpaired it. The nav DVD couldn't be ejected either.

I stopped the car several times and removed the keys, all to no avail.

Four hours later, after a night out with friends, I came back to the car and all was normal.

Any clue what might have happened? I have v25.02.
 

·
Freude am Fahren
Joined
·
19,695 Posts
This can be a sign of a CCC problem.

It's possible it might be remedied via a software upgrade but you should have the dealer check for any stored faults.
 

·
Registered
Joined
·
673 Posts
Check out the post that I started "IDrive display gone, no stereo . . . ".
It details the months of in and out of the shop and with BMW NA involment, etc. I did, I think, finally get it fixed, AGAIN, last week with a SW fix.

GOOD LUCK!
 

·
Registered
Joined
·
4,749 Posts
Got in my car this evening and my iDrive with nav was completely dark. I don't mean dim, I mean black and totally nonfunctional. It was so non-operable that the radio didn't work, the iDrive controller was totally loose and the steering wheel buttons didn't work. The only thing on the center console that did work was the HVAC controls and the manual gear shift lever. Bluetooth pairing remained, but it was impossible to make a phone call with my paired phone unless I unpaired it. The nav DVD couldn't be ejected either.

I stopped the car several times and removed the keys, all to no avail.

Four hours later, after a night out with friends, I came back to the car and all was normal.

Any clue what might have happened? I have v25.02.
Had the same problem awhile ago, dealer installed new software and everything is back to normal. Good luck
cheers
vern
 

·
Registered
Joined
·
52 Posts
Had the same issue:
- first timethis happened, went to the delaer: they detected a CCC fault; replaced CCC and upgraded to v25.02
- just 2 days ago, when starting the car, it seemed the idrive could not boot (no idrive functions screen blank, sometimes coming to white, then back to dark, controller loose etc...etc...: went back to the dealer: when they checked the car, everything was back to normal. They kept it in and performed a new SW upgrade; hope things go well now...
I shold thus definitely bring the car to the dealer for a hardware check !
 

·
Registered
Joined
·
63 Posts
I had the same issue with my idrive a couple months ago when my gf and I were coming back from a wedding when it was 95 degrees out. idrive was black, AC didn't work, no radio.... The next day idrive worked fine (radio and AC too). I read on e60.net that the car needs to 'reset itself' when it's turned off. This procedure can take an hour or so, otherwise you can remove and re-insert the radio/idrive fuse located in the trunk.

The dealer tried telling me it had to do with the XM radio I installed in the dash pocket and how I used a WIRED FM modulated connection. I thought the reason was BS, but I didn't want to remove my XM in an attempt to try and prove them wrong. I only drive the car once a week now since I just got a new Z4 Roadster, but so far no problems.
 

·
Registered
Joined
·
4,749 Posts
Had the same problem awhile ago, dealer installed new software and everything is back to normal. Good luck
cheers
vern
So much for the software fix. The problem came back this week and after the car being shut down for about 4 hours all is well again.
cheers
vern
 

·
Freude am Fahren
Joined
·
19,695 Posts
So much for the software fix. The problem came back this week and after the car being shut down for about 4 hours all is well again.
cheers
vern
Vern

Did they report any faults that showed up?

In my experience, a repetitive problem requires a CCC replacement. Also, there are some faults that will only be cleared with September 2007 sw.
 

·
Registered
Joined
·
300 Posts
Had the same problem awhile ago, dealer installed new software and everything is back to normal. Good luck
cheers
vern
My IPOD doesn't work. Note: My car sat in the garage for almost two months and I am not sure whether this was due to not using the car or any other I Drive problem.

Taking it back to the dealer on this Monday. Will let you know if this is related to the I drive.
 

·
E60 to E90 to E92
Joined
·
148 Posts
I had this problem too about a two months ago; same software version as stated above. I actually drove my car to the dealer with the screen black and had them take it in to diagnose the problem on the spot. Their head technician came out and told me that it has to do with the programming ... after repeated tests, they found stored faults "that the audio system was not initializing properly." So they re-installed the software again (which meant I had to go to Dinan to get their Stage 3 program re-installed too afterwards) and in the past two months, I've only had the screen go black on me 2 times. The dealer's solution: "if the black screen happens again, all you need to do is let the car enter sleep mode so the iDrive can reset itself, then start the car up." :confused:
 

·
Registered
Joined
·
4,749 Posts
Vern

Did they report any faults that showed up?

In my experience, a repetitive problem requires a CCC replacement. Also, there are some faults that will only be cleared with September 2007 sw.
Not realy. When it was in for service I told them about the CD tracks advance when the car is shut off and they have on the paper work SIB 61 14 03 program car 25.04 if that can mean anything.
cheers
vern
 

·
2007 550i, '13 X5, '02 X5
Joined
·
691 Posts
Well, I've never had the Black Screen problem until today. I had Progman upgraded to V26 a few weeks ago - prior to this version, I had V22 and never had the Black Screen issue. I parked the car to do some shopping at Best Buy and after about 45 minutes or so, I started up fine and the screen re-appeared like nothing ever happened. It was very weird driving without the IDrive - you never really understand how much you look at that screen until it's gone! Anyway, not having music was the worst part of all. I'll keep an eye on it and if it happens again - back to the dealer! :cry:
 
1 - 13 of 13 Posts
Top