BimmerFest BMW Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
hey there,
i have a 2007 bmw 335i with iDrive. my issue is that no sound is coming from the speakers. sometimes i get sound for like 5 seconds max and then it cuts off. also my bluetooth and voice command are not working at all.
does someone have this issue ? i was told it was the AMP. but if it was, shouldnt the audio not come on at all ?:dunno:
 

·
Registered
Joined
·
1,878 Posts
hey there,
i have a 2007 bmw 335i with iDrive. my issue is that no sound is coming from the speakers. sometimes i get sound for like 5 seconds max and then it cuts off. also my bluetooth and voice command are not working at all.
does someone have this issue ? i was told it was the AMP. but if it was, shouldnt the audio not come on at all ?:dunno:
Could still be a short in the amp. Everything routes through it.
 

·
Registered
Joined
·
1,878 Posts
can it be fixed ? or i need to get a new one ? i called BMW a week ago, they said that the AMP Control Unit Part Number 65129170386 costs 2100$
Wow. That's insane. Yeah you should be able to go aftermarket. I suggest you find Technic, he can give you better advice then I can. :thumbup:
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Yeaa, does anyone know a DYI on troubleshooting the electrical system on thoses cars ?
Does anyone know where the AMP is located? Is it the box in the trunk under the mat?


Sent from BimmerApp mobile app
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top