BimmerFest BMW Forum banner

Is it Battery or something else???

5561 Views 16 Replies 9 Participants Last post by  new_kid_in_town
Friends, back again seeking suggestions...

Yesterday morning I had to drive to a local Staples store about 7 miles away... Morning seems normal... No problem starting the car or driving... I was inside Staples for about 30-45 minutes... Came out of the store, put the key to the ignition and problem starts... Car wouldn't start!!!

Tried jump-starting the car with the help of a fellow gentleman... The car still wouldn't start... I could only hear a clicking sound... On the dashboard I could see some signs that would flicker and go away... Only noticeable thing is the sign of a clock with 00:00:00 written below it.

I never have seen that sign before and do not recall receiving any warning message that will tell me about any battery issue.

I had to call AAA... The guy came and also started with jump starting... Only difference is this time we were trying to jump start from behind connecting the cable directly to the battery terminals (first time we tried using the terminals under the hood)... Nothing worked until we tried charging the battery for almost 1 and half hour... The car finally started.

I drove back home and then left the car running for about another 20 minutes... I thought the problem was solved for the time being... I understood the battery would need replacement... In the afternoon I thought I should check it out and I found I'm back to square... This time I jump started the car myself using my other car and it took me about 30 minutes... Again, after starting I left it running for about 40 minutes... However, after I turned the engine off I couldn't turn it back on!!!

Any idea what could be the issue here... I doubt it is just the battery... All lights, AC everything turns on!!!

BTW, if you remember I reported my incident about low octane gas about a week back... I attached the link of that thread for your reference below... Is there any chance these two things are related???

http://www.bimmerfest.com/forums/showthread.php?t=636769

Once again thanks in advance for all your help!
1 - 17 of 17 Posts
Sounds like battery replacement time.

Sent from my C771 using Bimmer App
+1 on the battery and from what I have heard you NEVER jump the battery directly. I just remember reading that somewhere, not sure if its true or not but wouldn't take the chance. Also I can guarantee you are not the first person to put non premium grade gas into a 525, dont worry about that.
Do you think it can just happen like that? No signs of anything and then all in a sudden it just stops holding charge... Funny thing is lights and everything turns on like normal!!!

What do you suggest me to do from here? Dealer visit?
Is this your original OEM battery?
dead battery. stop jumping it unless you want to fry modules in the car. needs to be registered
I'm the 2nd owner... I have this car for last two years... I would think it is the OEM... It is white color... How do I say for sure?
Is this your original OEM battery?
Hmmm... I will be talking to the dealer today... Can I jump start it for one last time to take it for repair?
dead battery. stop jumping it unless you want to fry modules in the car. needs to be registered
Was it the battery? are all your issues resolved?
Hmmm... I will be talking to the dealer today... Can I jump start it for one last time to take it for repair?
Sounds to me like the last time the battery was changed they didn't register it. The same thing happened to me
and I just decided to register it and all was fine afterwards. There's an ongoing battle on this site about the whole registering the battery
thing. I really, really don't want to start that here. I'm just saying that in my case I purposley didn't register my battery after it's first replacement, and 7 months later it was doing practically what yours did. I asked myself how can a battery only last 7 months? Now years later no battery troubles. That's where I would start.
How do you regester the battery on replacement? Is it only a dealer item? That seems very strange!
I'll let this fly since you seem to be a new member, and possibly new to teh internetz and forums.


Searching is an awesome tool to find answers, BUT it's been covered. A lot.

Autologic or ISTA at an independent.
ISTA at the dealer.
There may be a few other scan tools that can register it, but not many.
Sorry guys... Hectic schedule at work kept me away from the topic...

OK... here is the update...

Talked to couple of dealers and my indy...

1st dealer said it requires replacement and reprogramming and would cost around $500.

Talked to my indy and he said he does NOT have the equipment to register and suggested me to contact the dealer... Surprising enough!!!

Called the 2nd dealer today... Very helpful response... The agent talked about replacing with a new more efficient battery which would cost about $800 (which includes battery plus programming)... he also talked about replacing with equivalent regular battery which would cost around $400... He however seems ignorant about the registration part... I then asked why I cannot replace it myself... He seems to be OK with that... To be safe, I asked if they could just do the registration part and he said they would be able to do that for half-hour labor cost.

I'm now trying to find the right (equivalent) battery for my car... I have attached the picture of my battery... The numbers that are found written on the battery are:

BMW S: 61 21 6 901 815
525679 - 10 11

Please let me know if you have any suggestions. Thanks!

Attachments

That battery isn't available at the dealer any longer.

So you upgrade to an AGM battery, thus the cost of programming and registering.
Sorry guys took this long to post back... I knew I owe this...

After waiting for couple of weeks I finally got it replaced with an equivalent Rayovac SLI95RH9 battery... I paid total $240 with installation.

Battery Link: http://www.batteriesplus.com/produc...cles-DASH--DASH-Rayovac-Maximum-SLI95RH9.aspx

I had then a guy from Craiglist registered my battery plus programmed my car (using INPA) for $60... All in all I spent $300 and got little bit extra (programming) than what the dealer originally offered for $550 :)

Attachments

I would personally be a little nervous about having some Bubba from Craigslist registering my battery and re-programming my car but I certainly hope it works out for you. Probably nothing to worry about.
I had then a guy from Craiglist registered my battery plus programmed my car (using INPA) for $60...
One of my very close friend (a veteran BMW owner) did a lot of research on this... He has got the required equipments as well (like cables and softwares)... But we decided NOT to do it but get it done by someone who did it before... I'm kinda a "risk taker"... At the end it worked out very well... The registration part is nothing but plugging a cable and click of a button kind of task... It comes back with a "successful" status that's all.

I had few other things done like closing windows, sunroof with the key, etc :)... So far things are good.
I would personally be a little nervous about having some Bubba from Craigslist registering my battery and re-programming my car but I certainly hope it works out for you. Probably nothing to worry about.
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top