BimmerFest BMW Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter · #1 ·
I love these 105 degree days! Not!

My 2009 328 e92 has ac that has not been blowing cold. Cool but not cold.

Added 134. Got cooler, but when I checked pressures found a problem - maybe.

When I checked pressures with manifold set it was 90 degrees out. Pressures after charging were : high side 260 psi at 2 k rpm. Low side was 32 psi at same rpm. When I added the134, the high side went up from 220 to 260 but low side never changed. Does this mean I ha be an obstructed expansion valve? The air definitely blows cooler now, but I Don't want to have a bigger problem lurking undiagnosed.

I would appreciate any input. Really enjoy the forum. Thanks for any and all help.
 

·
Registered
Joined
·
2,187 Posts
Dumb question but is the control knob on the middle vent set to "blue"? My car wash always seems to rotate it to red mixing in hot air.
 

·
Registered
Joined
·
8,080 Posts
Make sure re-circulation is on.

You should really have the AC system properly evacuated and filled. These AC systems are very sensitive to pressure. Too little or too much will cause poor performance. Even if it's just 1 or 2 pounds.
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #4 ·
Yes. All the way to cold. This would not affect the pressures though would it? From what I'm reading, the high side should read between 250 and 270 psi, and the low side 45-55. My high side is fine, but my low side is to low.
 
1 - 4 of 4 Posts
Top