BimmerFest BMW Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, looking fo help and perhaps someone has had this same issue. I have a 2003 525i and the keyless entry is not working, although the key will unlock the trunk. Coincidentally (hardly a coincidence I am sure) the interior console locck button does not work nor does the door opened interior lights.

New to the forum and thanks for any help in advance.
 

·
Coole Russen
Joined
·
1,304 Posts
Check your battery. More details please, also try to avoid run-on sentences, kinda hard to understand, especially last one with lights :dunno:
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
ok..

here goes again:

keyless entry not working, both keys
no chirp when pushed
key DOES open trunk
console lock/unlock button also does not work
interior lights do not come on when door opened

both keys were working prior to this happening

Thanks again
 

·
Coole Russen
Joined
·
1,304 Posts
I believe that's under front passenger door panel, some kind of computer that controls door locking mechanisms. That might be faulty. I don't think you have issues with battery if you car starts normally, trunk opens etc. Btw can you set alarm if you just insert key into front door and lock it? Try also to unlock it this way, will you get chirp then?
 

·
Coole Russen
Joined
·
1,304 Posts
My guess would be your key isn't working properly. Maybe bad battery, maybe something wrong with buttons :dunno: As for interior lights, turn on the ignition then hold the button(on the headliner, beside moonroof, which controls interior lights) for 5 seconds, then release it. Get out of the car. Lock the car, unlock it open the door, and see if it will turn on interior lights.
 

·
Registered
Joined
·
368 Posts
Check your fuse in the trunk. I've had this situation before on my 97 540i and my friends 2003 530i. Remotes won't work but will chirp if you physically use the keys to lock and unlock the doors. Although our interior lights and central locking switches were working fine. Once we replaced the blown fuse the remotes worked fine. It so funny how the "Dealer" diagnosed the problem as a bad remote on my friends 530i and was charging her over $200+ for a new remote and reprogramming it. So, check the fuse first. After replacing the fuse you'll have to reprogram the remotes (the owner's manual will show you how to do it). Hope this helps.
 

·
'00 540i Sport
Joined
·
202 Posts
Your problem may be caused by a bad gas door actuator. When if goes bad it blows the fuse. The fuse happens to be the same one for the remote door locks. Do a search on this forum for "gas door actuator" and you will find plenty of info on this subject.
 

·
Registered
Joined
·
33 Posts
I can vouch for the blown fuse scenario. Yesterday my key remote wouldn't work, got home tried the other key... no dice. I figured I was in for some $$$ repair, but then I found this post. Sure enough a fuse in the truck (53 maybe?) was blown, grabbed the spare and now all is good.

Not sure why it blew in the first place, if it happens again then I guess I'll need to go down this bad gas door actuator trail...
 

·
I Am The Machine
Joined
·
20,931 Posts
Yep, try the fuses. Dealers will always say it's a bigger problem.

Not a BMW, but my mom's minivan keyless entry stopped working. We went by the dealer to get a new battery for the remote, and they put the remote on a tester to check - battery was fine. The tech goes, "Well, your remote is fine, see? That means you need a new receiver for the signals. The part is about $350 and will take about 3 hours labor because it's in a tricky place."
I haven't had time to check, but I'm 99% sure it's just the fuse.
 

·
Registered
Joined
·
3 Posts
here goes again:

keyless entry not working, both keys
no chirp when pushed
key DOES open trunk
console lock/unlock button also does not work
interior lights do not come on when door opened

both keys were working prior to this happening

Thanks again
did you ever discover the solution to your problem?. i have exactly the same problems with my 2003 525i. it happened after i replaced a dead battery (my car was without battery power for about 24 hours).

i am new to this site. for safety, my e-mail is [email protected].

any advice or help you can provide me is greatly appreciated.

schauk
 

·
Registered
Joined
·
12,691 Posts
did you ever discover the solution to your problem?. i have exactly the same problems with my 2003 525i. it happened after i replaced a dead battery (my car was without battery power for about 24 hours).

i am new to this site. for safety, my e-mail is [email protected].

any advice or help you can provide me is greatly appreciated.

schauk
try reinitializing your keys...see the instructions below...bring both keys with you to the car...and follow the instructions to the "T"

Start the 2nd key on step #4...do NOT stick it into the ignition because it will cancel the 1st keys programming.

 

·
Registered
Joined
·
1 Posts
Dear Schauk, did QSilver7's recommendation to reinitialize keys work?

I am brand new to the forum, I have my 2001 530i for 3 weeks now. While I was working around the car lights, radio etc were on-short story the battery died. After jumping it (since I have a used bimmer, did not have the use manual so jumped it on the battery in the trunk-not using the part under the hood) remote does not open the trunk nor the trunk release inside driver's side. Key opens the trunk fine. When I press the trunk release while inside the car, I hear a click sound coming from glove compartment. After reading some posts, I checked all the fuses (in glow compartment & in trunk), they are OK. Before I try the trunk actuator I wanted to see if there is anything else I can do.

QSilver7, please feel free to comment.

When I get to the trunk actuator how can I tell it is busted, if it is the cause of this?

Other day I bought carsoft from ebay. Can that help? When I diagnosed found no error that seemed to relate to this issue.

I appreciate all your help/suggestions.
 
1 - 13 of 13 Posts
Top