BimmerFest BMW Forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
2,291 Posts
Discussion Starter · #1 ·
2 things...

first....I got a problem with the keyless entry on my 97 1.9. Somewhere there is a sensor that is broke or is misaligned. Here are the symptoms: Opera lights don't go out (indicating door is open). If the headlights are on and you turn off the car the "lights on" bong starts immediately (indicating door is open). Try to lock car with remote I get 3 chirps (indicating door is open or hood or trunk isn't closed). Lock (or unlock) car with key in driver door: all locks lock. Lock car in passenger door or trunk: only that lock works. Which leads me to believe the problem is with the passenger door (although the trunk lock not unlocking all doors is a bit puzzling). Can anybody help me with some instructions to how to check the passenger door sensor (or tell me if they think it is something else)? Ron? Jon? Andy?


second...anybody got an OE cassette unit sitting on the shelf gathering dustthey are looking to get rid of?

Thanks,
Bruce
97 Z3 1.9
95 M3
89 M3
 

·
Rest in peace, Coach
Joined
·
9,106 Posts
Bruce said:
2 things...

first....I got a problem with the keyless entry on my 97 1.9. Somewhere there is a sensor that is broke or is misaligned. Here are the symptoms: Opera lights don't go out (indicating door is open). If the headlights are on and you turn off the car the "lights on" bong starts immediately (indicating door is open). Try to lock car with remote I get 3 chirps (indicating door is open or hood or trunk isn't closed). Lock (or unlock) car with key in driver door: all locks lock. Lock car in passenger door or trunk: only that lock works. Which leads me to believe the problem is with the passenger door (although the trunk lock not unlocking all doors is a bit puzzling). Can anybody help me with some instructions to how to check the passenger door sensor (or tell me if they think it is something else)? Ron? Jon? Andy?

second...anybody got an OE cassette unit sitting on the shelf gathering dustthey are looking to get rid of?

Thanks,
Bruce
97 Z3 1.9
95 M3
89 M3
I have an OE cassett unit from my '98 1.9L sitting in my closet, however I no longer have the security code to activate the unit. Email me, [email protected] if you're interested.
 

·
Bimmerfest Founder
Joined
·
15,461 Posts
Bruce said:
I wonder if Jon can get the code?
Hey Bruce,

I'm done for the day, and tomorrow is my day off...

You should be able to call any BMW Center, and with the last 7 digits of the
VIN they can request your radio code, or get it through DCS I believe...

Let me know on Thursday if you still need some help.

--Jon
 

·
19,585 Miles
Joined
·
11,141 Posts
Bruce said:
Can anybody help me with some instructions to how to check the passenger door sensor (or tell me if they think it is something else
Finger the passenger door switch located in the B pillar (door jamb).
The alarm is looking for no grounds.
Any ground (switch closed) will give you the three chirps.
Can scan and send you the prints if you want.
 

·
Registered
Joined
·
2,291 Posts
Discussion Starter · #6 ·
Re: Re: keyless problem and WTB stock radio

Ron Stygar said:
Finger the passenger door switch located in the B pillar (door jamb).
The alarm is looking for no grounds.
Any ground (switch closed) will give you the three chirps.
Can scan and send you the prints if you want.
Ok I tried manually closing the lock with the door open. I don't see the switch anywhere (not that I was expecting to. I assume I need to take the door panel off?

Bruce
 

·
19,585 Miles
Joined
·
11,141 Posts
Re: Re: Re: keyless problem and WTB stock radio

Bruce said:
Ok I tried manually closing the lock with the door open. I don't see the switch anywhere (not that I was expecting to. I assume I need to take the door panel off?

Bruce
The switch is on the door jamb (B pillar). Stick your finger in the hole and the roller will push back. Will post a pic soon.
 

·
Rest in peace, Coach
Joined
·
9,106 Posts
Bruce, I'm still trying to locate the VIN...I can try stopping by my dealership this weekend and see if they have the VIN on their record. :dunno:
 

·
Registered
Joined
·
2,291 Posts
Discussion Starter · #10 ·
OK, so I just proved that I suffer from craniorectal inversion. :)



Don't ask me why I have this (Z3s are NOT supposed to have this feature), but I have positive pressure windows (i.e. when the door is opened the window goes down slightly, when closed it goes up to prevent not have excess pressure inside the car). Nice thing I have this feature as it proves (to my mind anyway) that the door sensors are working properly.

Next idea Ron? Is the trunk sensor easy to find?
 

·
19,585 Miles
Joined
·
11,141 Posts
Try unplugging the hood switch connector.




Then try unplugging the radio installed switch connector behind the radio where the pin on the back of the radio goes in.

 

·
Registered
Joined
·
2,291 Posts
Discussion Starter · #12 ·
Somehow I having a feeling my 2 problems (keyless entry and radio) are related....


I unplugged the hood switch, but what good does that do? It still beeps three times. If the hood switch is unplugged does the keyless entry unit then ignore the hood switch? Or does it assume the switch is closed?

Taking the radio out will have to wait til tomorrow. Plus I don't have a handy dandy Ron Stygar radio removal tool. :)

Thanks Ron,
Bruce


PS the radio problem has predated the keyless entry by a few months. The radio problem is the radio cuts out FM (only FM not AM or CD) for no reason. It sounds like a thunder storm with crackling and then nothing. I don't even think it is pulling a signal as the "ST" indicator goes out at the same time. I guess it could be an antenna problem....or....I screwed something up hard wiring the V1 (switched power taken from the radio).
 

·
19,585 Miles
Joined
·
11,141 Posts
Bruce said:

I unplugged the hood switch, but what good does that do? It still beeps three times. If the hood switch is unplugged does the keyless entry unit then ignore the hood switch? Or does it assume the switch is closed?
Hood closed = no ground = switch contact open. Unplugging the connector eliminated that as a possible problem.
If you had an ohmmeter you could check the sensor inputs at the alarm connector and see which one is causing the problem.

 

·
19,585 Miles
Joined
·
11,141 Posts
Bruce said:


Taking the radio out will have to wait til tomorrow. Plus I don't have a handy dandy Ron Stygar radio removal tool. :)

PS the radio problem has predated the keyless entry by a few months. The radio problem is the radio cuts out FM (only FM not AM or CD) for no reason. It sounds like a thunder storm with crackling and then nothing. I don't even think it is pulling a signal as the "ST" indicator goes out at the same time. I guess it could be an antenna problem....or....I screwed something up hard wiring the V1 (switched power taken from the radio).
You can purchase one from Richard Mix for $5.00 shipping included. [email protected].

http://www.unofficialbmw.com/all/stereo/radio_removal_tool.html

There is also a repair kit for the antenna lead if that turns out to be a problem.
 

·
Registered
Joined
·
2,291 Posts
Discussion Starter · #16 ·
I found the problem. While the window motor sounded like it was working when hitting the driver door switch it must not be enough to catisfy the alarm.

Ron...do you have a part number and price for a driver door switch?
 

·
19,585 Miles
Joined
·
11,141 Posts
Bruce said:

Ron...do you have a part number and price for a driver door switch?
I can't find the switch listed separately. I assume it's part of the striker 51 21 8 399 245 (same for left and right) $46.00 retail.
Double check when you order that's the case.
 

·
Registered
Joined
·
2,291 Posts
Discussion Starter · #18 ·
Ron Stygar said:
I can't find the switch listed separately. I assume it's part of the striker 51 21 8 399 245 (same for left and right) $46.00 retail.
Double check when you order that's the case.
Will do...Thanks Ron.
 

·
Registered
Joined
·
2,291 Posts
Discussion Starter · #19 ·
OK more info....

It appears that the locking mechanism isn't holding the door closed enough. If I push the door closed more the keyless works. The door looks like it isn't closed 100%.

Any fix/adjustment on the door mechanism?
 

·
19,585 Miles
Joined
·
11,141 Posts
Adjust the striker in a little without letting it cock or go up and down. Before you loosen it, mark its position using a marker or painters tape so you can do that. It is held in place with two T40 TORX screws.
 
1 - 20 of 23 Posts
Top