BimmerFest BMW Forum banner
1 - 7 of 7 Posts

·
archrenov8
Joined
·
219 Posts
Discussion Starter · #1 ·
Since I took delivery of my X3 on April 3, I have a series of odd little electrical problems. I wonder if they are all related somehow.

The mirrors do not respond to any programming inputs in the memory settings.

The seat memory is not holding my lumbar support setting. Every time I get in the car, the lumbar is filled firmer than I have saved it to.

The right mirror does not tilt down when reversing, no matter where I set the buttons on the driver's door.

The doors do not self lock when I start driving.

The Park Assist setting does not hold consistently. I leave it turned on, and then it deactivates as I am driving, which I expect it to, and then when I go to park, it is not always back on again.

It seems that when I put the car in reverse, the fog lights in the front bumper light up.

I have a service appointment in the morning to address these things.
 

·
Drink the koolaid or else
Joined
·
2,693 Posts
are you using the same key each time?
 

·
resU deretsigeR
Joined
·
6,259 Posts
The mirrors do not respond to any programming inputs in the memory settings.

The right mirror does not tilt down when reversing, no matter where I set the buttons on the driver's door.
Mirror failures are fairly common. We had to have the passenger mirror replaced on our 325i. It uses the same mechanism.

Do you use a pressure washer on your car? The mirror electronics can be damaged by high pressure water.

The doors do not self lock when I start driving.
Did they ever do that? It is not the default setting. You have to ask a dealer to program it in. You can also have the lock speed set. We have ours set to lock at 10MPH.

The Park Assist setting does not hold consistently. I leave it turned on, and then it deactivates as I am driving, which I expect it to, and then when I go to park, it is not always back on again.
It should turn on when you put the car in reverse or when you push the button. If it didn't work that way, it would start beeping in traffic.

It seems that when I put the car in reverse, the fog lights in the front bumper light up.

I have a service appointment in the morning to address these things.
You didn't name the car Christine did you?

Let us know what they find.
 

·
archrenov8
Joined
·
219 Posts
Discussion Starter · #4 ·

·
archrenov8
Joined
·
219 Posts
Discussion Starter · #5 ·
Mirror failures are fairly common. We had to have the passenger mirror replaced on our 325i. It uses the same mechanism.

Do you use a pressure washer on your car? The mirror electronics can be damaged by high pressure water.

Did they ever do that? It is not the default setting. You have to ask a dealer to program it in. You can also have the lock speed set. We have ours set to lock at 10MPH.

It should turn on when you put the car in reverse or when you push the button. If it didn't work that way, it would start beeping in traffic.

You didn't name the car Christine did you?

Let us know what they find.
Thanks for the info. They did not ask me any programming questions on delivery, and when I inquired, I got this blank gaze... I knew that couldn't be right.
 

·
Tar Heel Faithful
Joined
·
14,127 Posts
Make sure you are locking to save settings on the key. If you use key 1, leave the car unlocked, then use key 2 the next morning without pressing unlock (which is like *load settings*), then it will confuse the settings. The dealer can clear this up for you and set the positions, but you gotta remember to hit "unlock" to recall the settings.

Lumbar settings are not memorised. Only seat position, mirror position, and audio settings are memorised.

As part of the Cornering Lamps feature, the foglights will light up when the vehicle is put into Reverse. Also, when you signal to make a turn (i.e at an intersection), the single foglight on that respective side will light up, then self-extinguish after you have made the turn. This is normal operation.

I can't help you with the PDC, as our vehicle does not have this feature.
 

·
resU deretsigeR
Joined
·
6,259 Posts
Thanks for the info. They did not ask me any programming questions on delivery, and when I inquired, I got this blank gaze... I knew that couldn't be right.
Car/Key memory features are somewhat complex. Dealers are supposed to be trained on this and explain it to the customers at delivery.

Either read the manual or ask the dealer to have someone give you a thorough explanation.

There is a one page form with common programming options. You should have been given this form pre-delivery. You CA should have given this form to a service tech to program your car for you. Since your car has never been set, they should not charge you to do it now.

Link to post with the standard car/key memory form:

http://www.bimmerfest.com/forums/showthread.php?t=244704&highlight=key+memory+form

In addition to the 1-page form there are many more items that can be set. Most of them are in the owner's manual.

We asked for 2 things not on the standard form. Doors lock at 10MPH. (default is 5MPH)
Pathway lighting on longer than normal. 40s is default. I think ours on on for 120s.

We also have 3 blink turn signals. I can't recall if that is default or if we had it programmed.
 
1 - 7 of 7 Posts
Top