BimmerFest BMW Forum banner

low beam lights go on and off 1991 535

2944 Views 14 Replies 9 Participants Last post by  bojangles
When I turn on my headlights in low beam they stay on for 1 to 10 min and then turn off and on. high beam works and the error indication on the dash does not show the error. is there a relay i could look at? hope somebody can help.
btw treid to reverse the headlights from high to low but the connections are keyed :dunno:
1 - 15 of 15 Posts
Check the fuses. Won't hurt to change them out.
+1
check the fuses. Won't hurt to change them out.
it could be your light control module, the soldering in some components can break and cause this. I had the same problem, it went on to the point that i had to open my hood every time i wanted to use the lights so i could hit the module and they would work. best thing is to open it up if everything fails and check for any broken soldering if there are just solder it back up and works like new :thumbup:
so its not the fuse

checked all fuses and swapped them, did not help, does anyone know what relay is the one for low beam, high beam works. also it seems there is a connection between the ac and light, turn ac off light comes on, at least this time:(
which is the light control module?

just saw the answer,which is the light control module?:confused:
My fog lights were playing up on me like you described. My mate checked the resistance in the wires which connect to the h1 bulbs and they were just corroded. We soldered in some new wires and she was good to go. Wouldn't hurt to check the wires going to your headlights.
[/URL][/IMG]

this is the light control module.
but like arnz said check the wires first, the module should be like a last resort thing but then again you nver know :dunno:
For the symtoms he is having the first thing you look at is the LKM. See BMWe34.net for the fix and detailed pix. 30 cents worth of solder and five minuets of time. :thumbup::thumbup:
but like arnz said check the wires first, the module should be like a last resort thing but then again you nver know :dunno:
You can find them at the Local U pull yards . I picked up a spare for $14.

there have been 8 e34s in the local u pull here in FL is the last 7 months.
i had the same issue.i just got one from a junk yard as well.i still have the old one which i should've trashed but one from junk yard cost me $15.
No need to trash the old one. You can easily repair it. Junk yards aside, a rebuilt LKM is about 200 bucks. Repair it !

http://www.bmwe34.net/Wiki/tiki-index.php?page=LKM+and+Relay
i had the same issue.i just got one from a junk yard as well.i still have the old one which i should've trashed but one from junk yard cost me $15.
yeah that's what i was saying you can repair the light control module it's easy and i flollowed the same instructions cardriver posted :)
Yep had the same problem. Pulled the LKM out, resoldered all 4 realys...works beautifully!!
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top