BimmerFest BMW Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Hi.

BMW M3 2010 is unable to start. Car was fine and drove without any issues. Kept at the driveway for long time and then red steering lock was poping up on the speedo. One coder came and said it requires new CAS module and he did something but never came back to me later.

Now I can see that CAS module was updated when he came and the steering lock icon is gone from speed.

New issue. Now the steering wheel wont unlock even if the key is present. When attempting to start the ignition the car will just switch off. Resetting CAS and ELV is not helping. I got an error message on iDrive

"Engine start fault!
Please open and close the drivers door. Remove and insert the remote control into the ignition lock. In case of repeat occurrence, have the system checked by your BMW service"

I have attached ISTA diagnostic screen.

All I can think off is that previous coder did something wrong. Possibly failed CAS update?

Any help would be appreciated!! 20181218_164956.jpeg

Sent from my SM-G960F using Bimmerfest mobile app
 

·
Registered
Joined
·
763 Posts
Maybe he fried your cas module, try this disconnect battery overnight, than tey to reset elv, if that dont work i would try to update cas again, you can also try qnd install the ELV emulator, if that dont work mostly cas needs to be repaired
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Maybe he fried your cas module, try this disconnect battery overnight, than tey to reset elv, if that dont work i would try to update cas again, you can also try qnd install the ELV emulator, if that dont work mostly cas needs to be repaired
Thanks. After CAS update, does it require sync/initialize?

Thanks
 

·
Registered
Joined
·
763 Posts
Just default coding cas with ncs expert than do the elv counter reset, if you have inpa go to e89***8211;>functional jobs ***8212;>uif and see what ZB# is programed for cas, if he just updated your cas module than elv is still in software unless he flashed it to a non elv zb# with expert mode, and hopefully he used a power supply while flashing, even if there was a power drop while flashing he probably damaged your cas module post your ZB# and i will tell you.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
Just default coding cas with ncs expert than do the elv counter reset, if you have inpa go to e89***8211;>functional jobs ***8212;>uif and see what ZB# is programed for cas, if he just updated your cas module than elv is still in software unless he flashed it to a non elv zb# with expert mode, and hopefully he used a power supply while flashing, even if there was a power drop while flashing he probably damaged your cas module post your ZB# and i will tell you.
Please find screenshot attached. 20181218_160922.jpeg 20181218_160842.jpeg

Sent from my SM-G960F using Bimmerfest mobile app
 

·
Registered
Joined
·
763 Posts
ELV is still in your cas software
 

·
Registered
Joined
·
763 Posts
You can it wont hurt, just make sure you have a good charger connected or powersupply, key has to be out of the ignition, i would first unplug the battery let everything reset for at least 1 hr or overnight then try to do the elv counter reset if that dont help do the cas flash, or just go ExpertMode and flash with non elv software, google bmw winkfp ExpertMode, hopefully your cas is not damaged if it is you will need to take it out from car and read dump than write a correct file or replace cas but you will need tools to match isn.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
If anyone faces similar issue in the future, I have unplugged battery for the night and charged while unplugged. Next morning hooked up battery and the car started.

Just a note, I had additional key programmed which I had to hide from the car in case it was interfering with it.

Thanks Impac!

Sent from my SM-G960F using Bimmerfest mobile app
 
1 - 9 of 9 Posts
Top