BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1 (Edited)
the x5 is now 57K and just some weeks ago, I've been hearing noise from the engine bay as I turn left/right. But that only happened during the morning. Now, I hear it all day. I finally decided to check under the hood. So I found another problem...






There is barely any fluid in the reservoir. Is this where the coolant goes? Why are the leaks calicified?

No engine light warning about heat issue.
 

·
Registered
Joined
·
1,061 Posts
Check all your coolant hose near your reservoir for crack or breakage... The noise that you are hearing might come from your water pump or pulleys. Also, check all your drive belts ( ac belt, water pump and alternator belt)for any contamination of coolant.
 

·
Registered
Joined
·
98 Posts
That is definitely your coolant expansion tank and it appears to be shot. From the photos it seems that it has a hairline crack along that entire seam. The calcification is likely from using tap water that has lots of minerals in it that accumulate as the steam is escaping from the crack, as that tank is under a lot of pressure. It's odd that with a leak and lack of coolant that your coolant light isn't on constantly. I would replace that tank ASAP and maybe see if the coolant sensor has any issues as well.

As far as your other noises, they could be related or something else entirely. I would take the car to an quality indy shop or the dealer to have them diagnose that one.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #4
Good point about the tap water. I haven't ever been able to fill the coolant myself since i've just bought the x5 CPO two months ago. But I'm surprised that BMW dealer would have it filled with Tap!

As for the hairline crack, i wonder what would actually make crack? I have a scheduled appointment this Saturday due for service. I hope the diagnostics/service would be covered by CPO warranty.

The sound from the steering does seem to be coming from the belts near the front engine as petener999 mention. And the sound comes and goes.

Thanks!
 

·
Imola 4.6
Joined
·
340 Posts
OK, i know whats wrong... i just got a 4.6 and the same problem had happend.. it cost me about $120 and to fix it.. my antifreeze/coolant tank was leaking espesaly when it was under pressure... i had to fill up 2 to 3 containers per day. i took it to my trusted BMW expert and he changed the tank for $120 and it is problem free now.

ALSO, if/when you go to change it ask the mechanic that if the hoses connecting to the tank are in good contidtion or not? make sure its someone you trust so he wont lie and change it for no reason... but 90% chance id have to say your tank is leaking. not a big problem if you take care of it now. good luck..
 
1 - 5 of 5 Posts
Top