Bimmerfest BMW banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Good morning guys. Will you please assist me with my 320i E90 of 2006. The misfires and I have replace Vanoses, vvt motor, oxygen sensor before cat, coils and there is no change. It would at times take too long to respond even when the accelerator is full depressed. I have spent so much money on this car and it is still not right. I am in Pretoria, South Africa. Please assist.
 

·
Registered
Joined
·
2,187 Posts
No experience with this car. Sounds like you have tried most "throw at it" repairs. Is it just throwing a misfire code, nothing else? Assume you did plugs as well already.
 

·
Registered
Joined
·
883 Posts
Aren't misfires almost always either plugs or ignition coils? Sounds like you have replaced everything but the obvious! Also, codes should be thrown during a misfire... pull the codes to help narrow the issue.
 

·
Registered
Joined
·
1 Posts
Definitely check your plugs and coils. Your coil could be weak enough to missfire but not weak enough to through a code so if nothing shows up don't rule it out
 

·
Registered
Joined
·
8,080 Posts
Normally it's either coil packs, spark plugs, or injectors. The NA motors don't really have issues with injectors though.

A misfire can also be caused by bad fuel, a vacuum leak, bad timing, faulty wiring, low cylinder compression, etc.

Have you scanned the car? It sounds like you are throwing parts at the car, like mentioned above.

Swap plugs and coil packs to different cylinders and see if the misfire codes follow. If they do, you know which part is bad. If they don't it could be your injectors or any of the other issues I brought up above.
 
1 - 5 of 5 Posts
Top