BimmerFest BMW Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I am thinking of replacing my '06 325i with a 5-series x-drive, as I now have a long commute and live in Wisconsin. Looked at an '07 530xi, which is a lot softer than my 325i (stick/sport package) but I figure I could improve handling (in the summer at least) with 18's and summer tires. What troubled me the most, however, was a feeling of some lag between pressing the accelerator and accelerating - almost like turbo lag. Once over the initial lag, power and acceleration were good. I wondered if this was due to the transmission having to learn a different style, or is just one of the car's characteristics. It's a CPO with 44,000 miles; dealer is asking just under $33,000. They have an '08 535xi that wasn't available to test, but HPFP issues concern me.
 

·
Registered
Joined
·
204 Posts
I went from a 330xi to an 09 535x drive. The 330 had an unbearably rough ride, and I felt every bump on the road. I think it was the combination of the xi suspension (which is not very soft) and the run flat tires. I literally did not want to drive it. The 535 is a joy to drive with very comfortable ride quality without foregoing the sporty handling. I would recommend it. As for the lag when stepping on the accelerator, I've never experienced that in the 535.
 

·
Registered
Joined
·
173 Posts
I am thinking of replacing my '06 325i with a 5-series x-drive, as I now have a long commute and live in Wisconsin. Looked at an '07 530xi, which is a lot softer than my 325i (stick/sport package) but I figure I could improve handling (in the summer at least) with 18's and summer tires. What troubled me the most, however, was a feeling of some lag between pressing the accelerator and accelerating - almost like turbo lag. Once over the initial lag, power and acceleration were good. I wondered if this was due to the transmission having to learn a different style, or is just one of the car's characteristics. It's a CPO with 44,000 miles; dealer is asking just under $33,000. They have an '08 535xi that wasn't available to test, but HPFP issues concern me.
In my '07 525i (steptronic), there was a lag between pressing the accelerator and accelerating, when starting from a standstill. This was most noticeable in "D" mode, and virtually disappeared in "DS" mode, and was present from the day the car was delivered (with 44 miles on the clock). I would assume that a 530 of the same vintage would demonstrate the same behavior. So, is this "normal"? Based on a sample size of one, I would have to say "yes".
 
1 - 3 of 3 Posts
Top