BimmerFest BMW Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
189 Posts
Discussion Starter · #1 ·
Greetings,

Last night it was 34 degrees in the Modesto area of California. I turned on my BMW heater, and the passenger side was only blowing out cold air, the drivers side barely got warm.

Since having my motor replaced with a good used 2.8, my heater no longer seems to be working correctly. My LCD heater control panel switch is acting up, and now this past week some of the pixels seem to be missing.

Any suggestions, or was the engine change unrelated?

Jose F. Medeiros
San Jose, California
http://www.linkedin.com/in/josemedeiros
Thomas A. Edison: 'I have not failed. I've just found 10000 ways that won't work."
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #3 ·
Both climate control indicators are set to 90 degrees. It was working properly before the engine was swapped, both hoses going to the heater core appear connected from the engine compartment firewall. Do you happen to have a diagram that shows the proper coolant flow?
 

·
Registered
Joined
·
189 Posts
Discussion Starter · #4 ·
Today I looked at the three hoses coming off the firewall going to the heater core. All three appear hot to the touch, and both air intakes are sucking in air at the cabin filters, and appear to have equal suction on both passenger and drivers side. It does to appear to be warm on the passenger side when the ambient air temperature is not in it's 30's. The radiator coolant level appears fine, and it does not appear to be losing water. I think it may be best to flush the water heater by attaching a garden hose to the heater core outlet, and reversing the flow if that's possible?

Any suggestions are greatly appreciated.

Jose F. Medeiros, San Jose, Calif
 

·
Registered
Joined
·
268 Posts
Jose,
You are a little low on coolant. Here's what to do. Set the heat to 90, both sides and run it up to temperature from cold. The following morning, add coolant. Do this for as long as the level remains below the line in the expansion tank when cold. It will take several days for the air to completely bleed out.
Ned
 

·
Registered
Joined
·
77 Posts
hello everyone. i didn't want to make a new thread but my car blows no air at all on the passenger side. it blows luke warm air on the driver side and i tried to bleed the the system and it got a little better. people/forum members say it could be the heater control valve. what is the difference between the two way and three way ? but if i turn the dial to cold it blows air. car is 1997 528i/5
 

·
Registered
Joined
·
15,837 Posts
"Since having my motor replaced with a good used 2.8, my heater no longer seems to be working correctly."

The cooling system has air in it. Take it back to the mechanic who swapped the engine and have him fix it.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top