BimmerFest BMW Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi there,

In summary, test driving a '09 328i when it started raining near torrentially, which seemed fine as I slowed down for traction concerns with near an inch of water everywhere on road. All of a sudden, same throttle cruising in 6th at about 2100 rpm, the engine starts running horribly with an exhaust note that sounds darn near straight piped in volume increase and slight but noticeable gurgles, pops and bangs when letting off the throttle. Also, checking power in 4th at about 2900 rpm after slowing down and is pitiful, barely goes. My first (untrained and inexperienced) assumption is a misfire.

OBD scan with the seller, who seemed equally (and genuinely) surprised, revealed a P114D, post-cat fuel trim via O2 sensor system to lean (bank 2). Apparently, water damage is possible?

The test drive before the rain started when I got on the highway was great, everything was checking out and felt fine. Happen during the heavy rain, stopped, came by with equal amounts of water around, then when it subsided some and we drove in the city with less rain, went back to normal again.

My other idea was that the ton of water coming down and on the road might have gotten to a small leak near the post-cat O2 sensor and caused the read to go haywire, causing some sort of misread compensation in the combustion process?

I'm not quite experienced and this may be a naive guess, but it's my best one. Any ideas?


Before it's mentioned, yes there is a thread of nearly the exact same content that was incomplete and left me with questions after I ran into the same problem, titled
"E86 - P114D error code, drove through water logged dip in road".

Thanks for any tips,
 
1 - 1 of 1 Posts
Top