BimmerFest BMW Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
I have a 2014 335 with 14000 miles. A couple of weeks ago my wife complained the nav screen went black, radio did not work, back up cameras did not work, but the close to object chimes still functioned. My key fob still worked. But it did not last long. At first with my key the system would come on when starting the car, but would soon turn black. Now both keys get the same black screen results immediately at start.

Our previous 335 was a 2010 model and within a year we had a similar problem but worse! The screen turned red and nothing worked in the car - now widows would open, the car would not turn over and the gear lever was stuck as well. Finally got it fixed after several attempts. This problem was all over the posts but the dealer had not received any BMW bulletins.

Either I am just one really unlucky dude, or BMW has a problem. Going to the dealer next week. Over the phone he thinks it is a key problem.

Anyone else having a similar problem? And maybe a solution? My 335 is still on warrant, of course, but I want to be prepared with good info before bringing it in.

Thanks for your help.
 

·
Registered
Joined
·
8,177 Posts
Black screen = screen is not turning on

Red screen = screen turned on but is not getting video input from iDrive unit

I have a 2014 335 with 14000 miles. A couple of weeks ago my wife complained the nav screen went black, radio did not work, back up cameras did not work, but the close to object chimes still functioned. My key fob still worked. But it did not last long. At first with my key the system would come on when starting the car, but would soon turn black. Now both keys get the same black screen results immediately at start.

Our previous 335 was a 2010 model and within a year we had a similar problem but worse! The screen turned red and nothing worked in the car - now widows would open, the car would not turn over and the gear lever was stuck as well. Finally got it fixed after several attempts. This problem was all over the posts but the dealer had not received any BMW bulletins.

Either I am just one really unlucky dude, or BMW has a problem. Going to the dealer next week. Over the phone he thinks it is a key problem.

Anyone else having a similar problem? And maybe a solution? My 335 is still on warrant, of course, but I want to be prepared with good info before bringing it in.

Thanks for your help.
 

·
Registered
Joined
·
59 Posts
I have a 2016 435 convertible with 6000 miles. I had one instance around 5000 miles of my screen going blank right after start up. Radio button would not work either. Tried turning the car off and on several times. No joy. When I got home 30 minutes latter, I turned the car off, got out, and locked the car. When I got back behind the wheel a couple of minutes later, all systems normal.
 
1 - 4 of 4 Posts
Top