BimmerFest BMW Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
296 Posts
Discussion Starter · #1 · (Edited)
I have a 2013 F10 NBT

Used the following params to change my navigation voice from English (US) to English (UK) with ESys v3.24.3, PSdZData 56.2.

HU_NBT 3000 LANGUAGE_ENGLISH_UK : Change to: master, nicht_aktiv - Changes Navigation Voice from English to British English - Part 1
HU_NBT 3000 LANGUAGE_ENGLISH_US: Change to: nicht_aktiv, master - Changes Navigation Voice from English to British English - Part 2

It does work and I like the voice, BUT......

It seems that this simple voice change also changes the iDrive ConnectedDrive main menu to European menu. I have not initiated a Concierge call to see if corresponding menu choice of Info Plus still works. If it does then no harm, no foul. Although it would be nice to have the US menu back. Any way to do that?

Another anomaly, which was disconcerting was that in the Settings>Language/Units menu I saw that the language choices have changed (not surprising) to English UK/Spanish/French. Default (prior) US choices were: English/Spanish/French. That change in itself is OK, but out of curiosity I changed the menu selection to Spanish and as expected text and voice changed to Spanish. Problem was I could not change it back to English UK even though the menu selection had a check mark. I was stuck in Spanish. I had to go back to ESys and change the above settings back to default to get my English US text and voice back.

So, any other settings to change to make the simple UK navigation voice change work without all the other changes/problems being foisted upon me?

Thanks in advance.

Euro Menu:

 

·
Registered
Joined
·
296 Posts
Discussion Starter · #3 ·
Lucky you! :thumbup: Must be an NBT vs CIC thing. Wish I had her back. She seems much nicer than the other lady in the box. :p
 

·
Registered
Joined
·
3,813 Posts
Lucky you! :thumbup: Must be an NBT vs CIC thing. Wish I had her back. She seems much nicer than the other lady in the box. :p
If it helps/matters I don't remember having....

HU_NBT 3000 LANGUAGE_ENGLISH_US: Change to: nicht_aktiv, master - Changes Navigation Voice from English to British English

I only had the "English UK" option... I THINK. I do remember I had only one coding option for the British chick....
 

·
Registered
Joined
·
96 Posts
I haven't found anything. There was a thread around that suggested setting HU_NBT / NAVI_DESTINATION_INPUT_US --> nicht_activ would help, but on my F31 it didn't. I still get the UK menu items, and the satellite radio labels are completely messed up.

I decided to live with the menus and keep the British nav voice. She's definitely more polite... she says "Please." :)
 

·
Registered
Joined
·
296 Posts
Discussion Starter · #6 ·
Thanks. I made that parameter change as well and got the same results as you did, but I couldn't live with all the menu changes. Perhaps I'll give it another Go sometime. Just did a 1100 mile trip and having UK voice would have been nice. Torques me that it is so easy to do in my Garmins and with a much wider choice of voices. :mad: Voice input works better as well.
 

·
Registered
Joined
·
471 Posts
Just changed mine from english_us to english_uk. Yes the voice is much classier (the US one sounds like a cashier at Wal-Mart).

Removed spanish, added German and Italian to French. But I also included english_us as one of the language selections, and with english_uk as the master, it doesn't seem to function. Not that I want it, just an ovservation.

One other thing...I had to uncheck "automatic time" and reset the date and time -- they were blank -- before rechecking automatic.

So now there's a little German lesson when I use the NAV system....cool!
 

·
Registered
Joined
·
296 Posts
Discussion Starter · #8 ·
Are you able to change languages without any problems? After coding for English_UK I switched to Spanish to see how it would go and got stuck in that language. Even check marking UK again did not switch back or revert to English. I had to re-code to default to get it fixed.
 

·
Registered
Joined
·
471 Posts
Are you able to change languages without any problems? After coding for English_UK I switched to Spanish to see how it would go and got stuck in that language. Even check marking UK again did not switch back or revert to English. I had to re-code to default to get it fixed.
Yes. Tried all (_uk, german, french, _us, italian) and they all worked. Only "english" as it's listed on iDrive didn't seem to take.

I coded all of the following:
KOMBI -> 3008 PIA_Einheiten -> Funktionen -> Sprache -> uk
then...
HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_MASTER -> english_uk
HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_1 -> english_uk
HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_2 -> fransoesich
HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_3 -> deutsch
HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_4 -> english_us

plus...

HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_GERMAN = list
HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_ENGLISH_UK = master
HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_ENGLISH_US = list
HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_FRENCH = list
HU_NBT -> 3000 HMI -> Funktionen -> LANGUAGE_ITALIAN=list
 

·
Registered
Joined
·
38 Posts
For what it's worth, I also noticed that the destination input is somewhat different. All destination entry choices default to "n.t.a" which seems to mean "No Translation Available" - others have reported this as well. I think I'll probably revert to US English..too bad because I do like the UK voice much more.
 

·
Registered
Joined
·
11 Posts
Unmuted. Can only hear radio. Navigation in progress with turn by turn but no voice instructions


Sent from my iPhone using Tapatalk
 
1 - 16 of 16 Posts
Top