BimmerFest BMW Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hello everyone, iam a new member here!

I recently had this problem were my navi stoped working for some reason. I had a couple of addresses saved on my navigation, and when i tired to put a new adress in, a sign pops up and says something like, i need to delete my entires before adding a new address. So i deleted all all my entries and tried to put the new adress in, and again a little screen pops up and says i need to delete my entries. I dont know what else to do, any ideas?
 

·
Registered
Joined
·
17 Posts
Anyone ever had a problem with an 02 cd navigation system showing them in a different state even with the current location map in the unit? Any ideas? Can this unit be reset and do you think this will solve the problem?
 

·
Registered
Joined
·
34 Posts
Had the same problem with my navigation going CRAZY. It seems the navi is continuously spinning, and unfortunately, it doesn't know North from South. As well as New York from Connecticut. It shows me driving in water. If anyone knows of a reset, or a calibration, that'd be great!
 

·
Registered
Joined
·
17 Posts
I am just starting to figure out that this problem is probably not with the CD/DVD unit itself. I bought a used DVD unit (upgraded from the old CD unit) and installed it. The swap seems to have taken fine (I'll post more about it if I ever get the system fully operational) but had no impact on my problem (except that instead of showing that I am in Ohio, it now shows me in New Jersey). I bought this DVD unit out of New Jersey so all I can figure is that each unit must have some sort of internal memory of its last or latest location. I am however on to something that might explain this. It seems that this problem could be caused by either a bad TCU or antenna. I will post more as I find some answers.
 

·
Registered
Joined
·
313 Posts
This probably doesn't help too much... but I was reading the manual and it mentions that if the GPS signal is obstructed the GPS logo in the top right corner of the navigation view will disappear (it's a picture of the earth with GPS written over it and little dots that I believe are supposed to represent satellites:rofl:). If you don't see that symbol or it looks grayed out or something, then it would seem to confirm your antenna / TCU theory.
 

·
Registered
Joined
·
313 Posts
In case it wasn't clear, what I was trying to get at with the GPS satellite logo disappearing is that if it is permanently gone (never shows up) then you probably never are getting a signal which could mean an antenna problem or receiver problem...
 

·
Registered
Joined
·
17 Posts
teejaylentz - First let me thank you for your help. I think you maybe on to something. As I remember, the picture of the earth on the right top side of my navigation screen maybe gray or something similar. I will check on this and get back to you.
 
1 - 10 of 10 Posts
Top