BimmerFest BMW Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
Hello guys, I am new to the site and just recently purchased a 02 bmw with 70k miles on it, today the navigation stopped working ans so did the radio/cd player. the I-Drive monitor freezes on startup and all i can control on the dash is the Ac/ heater buttons, I was just wondering if anybody had this problem, how they got it fixed and How much it cost to get it done.
Ps I have a DVD based navigation system. Thanks In advance for your timely and courteous response. God Bless
 

·
E65/E66 Helper Man.......
Joined
·
1,511 Posts
most bus fault... something in your most chain is causing an error... most common causes are navigation computers and logic 7 amps, if equipped... you can try a most bus reset, but if that doesnt work you may require a most bus diagnosis form the dealer...

you can also go the dealer and buy most jumpers, and jump the fiber cables on the logic 7 amp and navigation drive to help diagnose where the cause may be...
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #6 ·
Okay so I took the car to the dealership today and I.m currently awaiting a response from them, I hope it won't cost me a lot of money for the fix. Does Anyone think it will?
 

·
Registered
Joined
·
850 Posts
My guess LOGIC 7 AMP went bad
 

·
E65/E66 Helper Man.......
Joined
·
1,511 Posts
Okay so I took the car to the dealership today and I.m currently awaiting a response from them, I hope it won't cost me a lot of money for the fix. Does Anyone think it will?
i hate to bum you out, but this can be a very costly repair if your car is not covered under warranty... most likely, at least 1 component will need to be replaced, and once replaced it will require vehicle encoding...
 

·
Registered
Joined
·
12,023 Posts
another02 bites the dust:(
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #10 ·
My guess LOGIC 7 AMP went bad
Just curious, what does the LOGIC 7 AMP have to do with the navigation not working and the I-Drive monitor freezing on startup? I'm Also hoping someone who had this similar problem could give me an estimate of how much they spent. Thanks
 
1 - 11 of 11 Posts
Top