BimmerFest BMW Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I was wondering if anyone knows what would cause the electrical to quit on the interior of the car. My wipers, door locks, windows and sunroof all stop working and randomly come back on and shut off again. Is there a relay that is bad or do I need to take my car in to have someone check out what is wrong?
 

·
Humble E34 lover
Joined
·
5,519 Posts
There is a good possibility that one or more of the ground connections are loose. If you are handy with electrical and mechanical stuff, start checking your grounds. Start with the battery and make sure that the terminals are tight. Trace the positive terminal heading back towards the engine bay. There are a coupld of things called "fusible links". These are essentially large, flat fuses. They are known to fail at times. I believe one is under the seat.

Here is a link to a site discussing fusible links:

http://www.bmwe34.net/E34main/Maintenance/Electrical/Fusible_link.htm

There are several ground points on the car. You can find 2 (I believe) under the hood. Make sure they are all tight.

One word of advice, obtain a copy of the Bentley manual (hard copy or downloadable version which can be easily searched for). Read it and get to know it.

Anyway, checking all of your ground points is the best place to start your diagnosis.

Hope this helps some.
Steve
 

·
Lucky to drive a BMW
Joined
·
1,356 Posts
Could Be this part research "GM module." Then find one at a salvage yard for a test.http://www.data.bmrparts.com/bmwparts/36_23288404453507U.html..... Also try applying pressure on the componants /relays under back seat see if any thing works wile doing this .A member reported have loose contacts in that area of relays under the back seat.
 

Attachments

·
Registered
Joined
·
14 Posts
Discussion Starter · #4 ·
Hey Steve I checked that first fused link and found that it had popped. Thanks that ended up being an easy diagnosis, but now I am trying to find a new one so far I have not been able to find 1 at the local parts store so I guess I will have to try the BMW dealer. Thanks again for the help.
 

·
Humble E34 lover
Joined
·
5,519 Posts
Hey Steve I checked that first fused link and found that it had popped. Thanks that ended up being an easy diagnosis, but now I am trying to find a new one so far I have not been able to find 1 at the local parts store so I guess I will have to try the BMW dealer. Thanks again for the help.
I'm glad you found it. I did a quick search on BAV Auto and found one. Just put in your model and search for "fusible link". It's like $11.95.

Part #: 61 13 1 382 065.

There may be other sites that sell them as well. If you need it now, then the dealer is the best way to go.

Steve
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top