BimmerFest BMW Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
I got my car checked yesterday for the ABS, Brake and DSC lights, the computer said the right front sensor(wire) I changed the whole sensor, brake switch (plausibility) changed that anyways, but it still gives the error for the sensor (same and same error for wire), any ideas guys and it also gives the error for the pressure sensor do you guys think I should go ahead and change that too, or wait till I figure out with the ABS Sensor

Thanks for the input in advance
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #3 ·
Filled the brake fluid

Yes I did checked the brake fluid and it was little down so I filled it up to the max mark, and about changing the right sensor I changed the one which computer asked me change, but the old sensor didnt look like it was damaged unless there was some internal damage
 

·
Registered
Joined
·
462 Posts
Could it be that it wasn't the sensor itself, but the wiring for the sensor before it, got crimped or torn, and that's why the error is still there? I would follow that wire and look for any tears. Also not trying to insult your intelligence or any thing, but right front sensor would be the passenger side. Is your speedometer working btw?
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #5 ·
yes the speedometer and everything else works just fine, and yes I know the right front side is passenger side. I will definitely follow the fire and see if there is anything wrong with that.

thanks
 
1 - 5 of 5 Posts
Top