BimmerFest BMW Forum banner
1 - 16 of 16 Posts

· Registered
Joined
·
692 Posts
Discussion Starter · #1 · (Edited)
For the past two summers whenever I drive my 6er at night the freaking passenger side low beam flickers once every 2-3 minutes.. For the past 2 months though the light will flicker every 2-3 minutes but will then eventually stay off completely and give me an error in iDrive stating that I have a passenger low beam malfunction.. This passenger side assembly also has an adaptive headlamp error that has always popped up.

Now, I have replaced the red ignitor, the Ballast on the bottom of the headlight assembly, and the actual D2S bulb (twice). The bulbs are the 8000k eBay bulbs, I think they are called Super Vision or something.. I have been thinking that the bulbs may be the problem, but then if the bulbs were the problem wouldn't the driver side bulb also be doing the same thing?? There was condensation inside of the headlight a while back when I went to one of those conveyor belt car washes but no since then because I only hand wash the car now.

I am about to blow this car up or get rid of it because this is frustrating me so much.. Im thinking of taking the car to the dealer for a diagnosis of the problem, but they are pretty much guaranteed to screw me on the diagnostic charge.

Does anyone have any suggestions or have you had any problems similar to this?? Should I replace the headlight bulbs with some Phillips brand headlight bulbs? Is it possible for the little Stepper Motor Controller (SMC) on the side of the headlight could be causing this problem?

Looks like the cheapest Brand New headlamp is around $1200 shipped, and the cheapest used (Insurance Quality) Headlamp assembly is $800 shipped... Thinking of pulling the trigger on the used one...
 

· Registered
Joined
·
682 Posts
the design on these headlight assembly are horrible,i don't take my car in a car wash anymore just to save the ballasts,i know its a big job but have you tried swapping the headlights from left to right to see if its the headlight or a wiring issue?
the front bumper is a 20 minute job to remove
 

· Registered
Joined
·
692 Posts
Discussion Starter · #3 ·
I have swapped everything but the actual headlight assembly lol.


Sent from my iPhone using Tapatalk
 

· Registered
Joined
·
2,725 Posts
For the past two summers whenever I drive my 6er at night the freaking passenger side low beam flickers once every 2-3 minutes.. For the past 2 months though the light will flicker every 2-3 minutes but will then eventually stay off completely and give me an error in iDrive stating that I have a passenger low beam malfunction.. This passenger side assembly also has an adaptive headlamp error that has always popped up.

Now, I have replaced the red ignitor, the Ballast on the bottom of the headlight assembly, and the actual D2S bulb (twice). The bulbs are the 8000k eBay bulbs, I think they are called Super Vision or something.. I have been thinking that the bulbs may be the problem, but then if the bulbs were the problem wouldn't the driver side bulb also be doing the same thing?? There was condensation inside of the headlight a while back when I went to one of those conveyor belt car washes but no since then because I only hand wash the car now.

I am about to blow this car up or get rid of it because this is frustrating me so much.. Im thinking of taking the car to the dealer for a diagnosis of the problem, but they are pretty much guaranteed to screw me on the diagnostic charge.

Does anyone have any suggestions or have you had any problems similar to this?? Should I replace the headlight bulbs with some Phillips brand headlight bulbs? Is it possible for the little Stepper Motor Controller (SMC) on the side of the headlight could be causing this problem?

Looks like the cheapest Brand New headlamp is around $1200 shipped, and the cheapest used (Insurance Quality) Headlamp assembly is $800 shipped... Thinking of pulling the trigger on the used one...
The module on the side is not for the stepper motor. It's the lighting control module and could very well be the issue. The stepper motor is on the bottom of the light housing.

I would remove the light housing (yes I know a PITA :rolleyes:) and look carefully at all connections. If all looks good I would swap that module with the drivers side and see if if follows the module.
 

· Registered
Joined
·
692 Posts
Discussion Starter · #5 ·
The module on the side is not for the stepper motor. It's the lighting control module and could very well be the issue. The stepper motor is on the bottom of the light housing.

I would remove the light housing (yes I know a PITA :rolleyes:) and look carefully at all connections. If all looks good I would swap that module with the drivers side and see if if follows the module.
Hmmm. That's interesting because I've always been told and through research have seen that the bottom electrical unit was the ballast/headlight control unit and the smaller side unit was the SMC unit. I will try switching the small side box to the driver side to see what happens.
 

· Registered
Joined
·
2,725 Posts
Hmmm. That's interesting because I've always been told and through research have seen that the bottom electrical unit was the ballast/headlight control unit and the smaller side unit was the SMC unit. I will try switching the small side box to the driver side to see what happens.
Unfortunately, I can tell you from experience that the bottom module is for the stepper motor control.

I can also tell you that replacing the module is what turned me on to the fact that dealers charge whatever they want for parts and the prices vary wildly. Just in case you need to replace a component shop around.

Good luck.
 

· Registered
Joined
·
692 Posts
Discussion Starter · #7 ·
Unfortunately, I can tell you from experience that the bottom module is for the stepper motor control.

I can also tell you that replacing the module is what turned me on to the fact that dealers charge whatever they want for parts and the prices vary wildly. Just in case you need to replace a component shop around.

Good luck.
Hey roseng. The picture below is the part that I'm referring to. It even says SMC on it. But I'm going to try swapping it this week to see if it solves the problem.

 

· Registered
Joined
·
692 Posts
Discussion Starter · #8 ·
Alright so here is an update.. I went out to my garage and took the front bumper off, swapped the small control units to the opposite side and the problem still occurs on the passenger side.. Unfortunately its looking like I need to purchase a new or used headlamp assembly...
 

· Registered
Joined
·
2,725 Posts
Alright so here is an update.. I went out to my garage and took the front bumper off, swapped the small control units to the opposite side and the problem still occurs on the passenger side.. Unfortunately its looking like I need to purchase a new or used headlamp assembly...
OK, one more thing to try before you spend $$$.

With the headlights configured as normal with modules on them, swap the left and right assemblies.

If it follows the headlight it's in there somewhere. If it stays on that side you have a wiring or LM issue.

Question, did you swap the bottom modules just to see if it followed that?
 

· Registered
Joined
·
692 Posts
Discussion Starter · #10 ·
OK, one more thing to try before you spend $$$.

With the headlights configured as normal with modules on them, swap the left and right assemblies.

If it follows the headlight it's in there somewhere. If it stays on that side you have a wiring or LM issue.

Question, did you swap the bottom modules just to see if it followed that?
yup, swapped the bottom modules last month.. going to swap the headlight assemblies tomorrow and I'll report back then..

Thanks for the help roseng.
 

· Super Moderator
Joined
·
10,328 Posts
Swap the entire headlight to the opposite side, & see if the problem follows. Yes you can plug the light in the other side, I thought the same thing when Gary told me to do it. If your problem follows the light, it is internal to the light itself, or the other control module. Below are some pics of what the wiring can look like after water damage has occurred inside of the light, I only got one warning, & this is what was found. After seeing the damage, I would never spend 800.00 on a used headlight. I have just gone thru this nightmare. I tried to save the light, but the wiring harness just kept falling apart. Some of my pics did not come out, but I can take more. Wire were shorted & open. The fiber optics had no insulation on them at all. The pics are after some attempt at repair.

 photo 20150910_203930_zps5e9s16s6.jpg

Fiber Optics
 photo 20150910_122804_zpsfx5v06uf.jpg
 

· Registered
Joined
·
692 Posts
Discussion Starter · #12 ·
HerbP-

is that top pic of the harness the plug that actually plugs into the headlight?? Or is that the other end of the plug?? I ask because the end of my plug that plugs into the headlight housing is not even close to looking that bad.
 

· Registered
Joined
·
692 Posts
Discussion Starter · #14 ·
That is the inside of the headlight plug, which the plug you are looking at plugs into. If you have your light out, remove the doors & see if any black plastic from the harness starts to fall out?
I will check that out tomorrow also.. thanks..
 

· Registered
Joined
·
692 Posts
Discussion Starter · #15 ·
I swapped the headlight assemblies to the opposite side and the problem followed the passenger headlight. So I guess the conclusion is a bad headlight from the moisture, which freaking sucks. I'm definitely not paying $1300 for a new headlight, I would rather get the used one for $800 shipped with a 90 day warranty. Don't know how long I will be keeping this car anyway.
 

· Registered
Joined
·
2,725 Posts
I swapped the headlight assemblies to the opposite side and the problem followed the passenger headlight. So I guess the conclusion is a bad headlight from the moisture, which freaking sucks. I'm definitely not paying $1300 for a new headlight, I would rather get the used one for $800 shipped with a 90 day warranty. Don't know how long I will be keeping this car anyway.
Maybe these will help
http://www.ebay.com/itm/04-05-06-BMW-E63-E64-Xenon-HID-Headlight-LH-Left-Driver-Side-645Ci-650i-OEM-
/111748857833?fits=Make%3ABMW&hash=item1a04c03fe9&vxp=mtr

http://www.ebay.com/itm/2004-2005-2...E64-/201426493047?hash=item2ee5f45e77&vxp=mtr
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top