BimmerFest BMW Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hi All,

I collected my new E90 330i last week and i love the car. I am a UK expat living in Saudi Arabia and i traded my E46 325i for the 330i and I can't believe how far advanced the E90 is compared to the E46 (also a great car).

I have iDrive/Nav/Bluetooth etc etc however I'm having some difficulty with the speed limit warning as it has been set at 120kph and I can't get any success in trying to reset it to a higher speed. I have successfully changed it in iDrive and the screen shows the new limit (135kph) but the chime still comes at 120 and "LIMIT" is displayed in the dash controls in a red circle and the monitor says "Speed limit exceeded" along the bottom of the screen. I believe all Middle East cars have to conform to some kind of warning at over 120kph therefore I guess this has been done by BMW? Does anyone know how to overcome this as it is a bit annoying, especially with the monitor as the CD-track-clock info is covered over by the "Speed limit exceeded" info and is not shown until I reduce speed below 120? It's not the end of the world but I would like to get rid of this chime at this low speed for the future.

BTW, I have used the voice command to change the limit successfully and also the "accept current speed" function and the monitor shows the new limits I have input. It still chimes at 120????

Any help would be much appreciated.
 

·
Registered
Joined
·
197 Posts
If you have reset it correctly via the iDrive menu, there's not much anyone here can do for you. Take it to the dealer and see what they can do. If it's a requirement in your country, then you are stuck. :(

Congrats on the car.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks Gripster for the reply - I was afraid this was going to be true!!

Interestingly, the E46 325i had a similar set-up but after passing through 120kph the dash display would show the limit in flashing digits with the same chime but after 5 seconds or so it would return to the normal display (outside temp, clock etc). It would remain like this until I reduced speed below 120 and then same again as I increased speed. It's odd that the new car doesn't behave like this and blocks my view of the preferred information on the dash display and the monitor continually until I reduce below 120??? I assumed that this was a program entry that could be changed. The dealer can't (won't) help.

Otherwise the car is fantastic and I've been pretty good with the break-in procedure. Now covered 800kms and working towards getting through the 2000kms. The car is Monaco blue with individual interior and she has just about every option I can think of - truly a great car!
 
1 - 3 of 3 Posts
Top