BimmerFest BMW Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi my son just bought a 2002 320i...he's on his way to Dallas from Winnipeg,MB and it turns out the oil engine light turned on sporadicaly....he also says the oil is low. The oil was just changed two days ago,,, I found the bill and the service garage placed pennzoil 5w30 oil in (I;m guessing non-synthetic) I have suggested to my son that he gets the oil and possibly filter replaced asap as the engine should be running synthetic. Is there a possiblity that the regular oil could damage the motor and cause excessive oil consumption.
 

·
Premium Member
Joined
·
14,837 Posts
Not in my opinion.
 

·
Registered
Joined
·
99 Posts
Ask him if the yellow oil light comes on for about 10 seconds or so after the is started and does not come on again while in operation. It is probably a failed sensor just have it replaced next time he has the oil changed. This has been addressed many time on E46 threads.

www.oembimmerparts.com, a fest sponsor, has one for $90 Click Here

E46 3-SERIES OIL LEVEL SENDING UNIT WITH SEAL OEM - Looks like this
 

·
Registered
Joined
·
99 Posts
As for loosing oil thats a tough call, is he checking the oil on a hot or cold engine? Cold engine will show more oil then a warm engine because the oil pump has recently run and pulled oil from the pan.
 

·
Keeping it surreal
Joined
·
43,207 Posts
Don`t worry about it....BMW oil-level sensors are known to be spastic. As long as the dipstick reads OK, you`re OK....and no, the dino oil won`t cause the engine to self-destruct. (I would replace it with synthetic at 3000 miles, though)
 

·
Premium Member
Joined
·
14,837 Posts
ok, so the oil consumption could be something else?
Could be any number of things.

1) Oil level low via dipstick - Garage underfilled oil - replenish
2) Oil level low via dipstick - oil is leaking - check under car, identify leak, rectify, replenish
3) Oil level is ok via dipstick, Yellow oil light still illuminates - Oil sensor is faulty - rectify.

I don't see how you can determine "excessive oil consumption" if the car has been with you two days?

As FB said, dino oil will not kill the engine. But yes, if it were my car, I'd run it one service interval and then change to BMW OEM 5W-30 synthetic.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
thanks for good advice

thanks for the good advice....my son is faithfully checking oil level on his way.....he's going to have oil changed to syn when he gets to Dallas. The oil light is still turning on occasionally. The last I spoke to him he said the oil was quite dirty and he has added a quart for each 500 miles approx.
 

·
Registered
Joined
·
99 Posts
It doesnt sound like changing the oil is going to fix the problem if he is able to add that much oil every 500 miles. At that rate he is either burning it or loosing it. Either way that problem will need to be fixed first.
 

·
Registered
Joined
·
308 Posts
Is there smoke coming from the tail pipe?
Is there oil around the oil filter housing?

Something is wrong here. Synthetic or not, this is not normal. A synthetic oil change will be a waste of money at this point.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
any suggestions for bmw service in Dallas

My son did make it to Dallas ok , although he now says the motor is reving erratically.
He needs to have it looked at...any suggestions for the Dallas Forth Worth area? or would the local BMW dealer be the best bet to trouble shoot?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
Hey guys, Update, so im in dallas, and my car has been acting up, oil light came on again so i put another liter in.. so somethings weird, but driving when staying at a steady pace say 60mph, sitting at 2500rpm's, every 2 seconds it will go to 2900rpm's then back down, and makes a boggin down sound.. (also seems to be rmp's seem to be higher when accelerating) Seems to happen at every speed, tried cruise controll, same thing just non stop up down up down rmp's.. with a horrible sound coming from the motor (deep bogging down sound).. Anyone had this happen to them or got any idea what is it? could it be from regular oil... Ive gone 2500km's and its burned prob 8L's of oil.. (or i guess could be a possible leak? but iuno about that).. Im going to bring her to bmw here hopefully tomorow but kinda on a tight budget so would like to figure it out my self if i can before they go crazy on it.. Any help would be wicked thanks
 

·
Registered
Joined
·
99 Posts
Anyone had this happen to them or got any idea what is it? could it be from regular oil... Ive gone 2500km's and its burned prob 8L's of oil.. (or i guess could be a possible leak? but iuno about that).. Im going to bring her to bmw here hopefully tomorow but kinda on a tight budget so would like to figure it out my self if i can before they go crazy on it.. Any help would be wicked thanks
It's not the grade of oil, should read your own post, hehe.

Have you had your codes read? You should at least go to Autozone or something and ask them to read your codes. From what I have read it sounds like you have a vacuum leak, you can test it by taking off your oil cap and placing a sturdy plastic over the opening if it starts to gets sucked in you have a leak.

All of this info is easily found using the search tool as well as many DIY's once you find the source of the problem which will most likely be a failed hose, gasket or seal. Tight budgets are no problem if you are willing to buy the parts a bentley manual and use search you will find a community of people who have helped others fix the parts you will be working on, as I have. Welcome to the fest, pay it forward.
 

·
Registered
Joined
·
373 Posts
Hey guys, Update, so im in dallas, and my car has been acting up, oil light came on again so i put another liter in.. so somethings weird, but driving when staying at a steady pace say 60mph, sitting at 2500rpm's, every 2 seconds it will go to 2900rpm's then back down, and makes a boggin down sound.. (also seems to be rmp's seem to be higher when accelerating) Seems to happen at every speed, tried cruise controll, same thing just non stop up down up down rmp's.. with a horrible sound coming from the motor (deep bogging down sound).. Anyone had this happen to them or got any idea what is it? could it be from regular oil... Ive gone 2500km's and its burned prob 8L's of oil.. (or i guess could be a possible leak? but iuno about that).. Im going to bring her to bmw here hopefully tomorow but kinda on a tight budget so would like to figure it out my self if i can before they go crazy on it.. Any help would be wicked thanks
If you are going through 8 liters of oil in 1500 miles, you certainly should either be seeing extensive smoking or seeing obvious signs of leaking.:confused:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #18
OK so took it in... they put in a new (vacuum i think) crank valve and oil hose... 1500 dollars later.... rpm thing is still doing the same thing... and gas millage is just redicilous high the gage is stuck at 20 (km/l) till you get into 5th basically.. and still making the sound etc... i got a video that ill post up of it doing it so you guys can see.. but i kinda need to get back to canada so im hoping i can make it back.. so do you think itd be something transmission wise? they said they havent seen anything like it (i got it done at krausers auto in lewisville,tx)..

heres the video

http://tinypic.com/player.php?v=25slycn&s=6
 

·
Registered
Joined
·
9 Posts
Discussion Starter #19
btw there was a small leak and crazy black smoke coming out, so they fixed that and put synthetic in, so oil consumption should be normal now
 
1 - 20 of 20 Posts
Top