BimmerFest BMW Forum banner

1 - 20 of 41 Posts

·
Registered
Joined
·
1,401 Posts
Discussion Starter · #1 ·
This code was found by JEG23, I am just helping him out by posting this.

This works great on my car 2013 F06 and Andreo's car 2013 F12 but didn't work on JEG23's car 2011 F10. This should work on any F12/F13/F06 2012+, but we are not sure about any other models.

Below is JEG23's write up, all credit goes to him.

New Code-Night Vision with Background Pedestrian Detection

I know this is of limited interest, since only a few of you have the Night Vision camera, but these code changes will increase the utility of this system, so I decided to post it. Its increased abilities may even lead others to include this option for their next vehicle.

Night Vision with pedestrian detection uses an infrared camera to record the area in front of the vehicle and display the image on the Control Display.

The picture is a heat image. The system has an integrated pedestrian detection function that detects pedestrians and cyclists. Warm objects that are similar in shape to human beings are detected by the system.

Warning of people in danger

If the system detects a person in the defined area in front of the vehicle and if there is the danger of a collision with this person, a warning symbol appears in the Control Display and Head-up Display.

One problem (in the F10) with the system is that the camera has to be turned on and actively showing the image before pedestrian warnings can be issued. Very few of us run around with the infrared camera turned on occupying most of the central information display. With the changes below, your system will essentially be on at all times (at night of course), monitoring for pedestrians in the background and providing you warnings via the cluster and/or the HUD.

The following warnings will be shown if there is imminent danger of collision.

Change the following codes:

KOMBI->3003 FZG_Ausstattung, 10->FGS_NIVI_KI_ENABLE->aktiv (default is nicht_aktiv)

NIV->3000 Basic_Functions, 20->CC_Messages->ACTIVE_NV2P_BD (default is ACTIVE_NV2)

NIV->3250 Pedestrian_1, 40->USE_ACUTE_WARNING->AW_ON (default is AW_OFF)

NIV->3250 Pedestrian_1, 40->USE_ACUTE_SOUND->AW_ON (default is AW_OFF)

NIV->3252 Pedestrian_3, 40->R1_ACTIVE->AW_ON (default is AW_OFF)

NIV->3253 Pedestrian_4, 80->PED_DET_IN_BACKGROUND->ON (default is OFF)

NIV->3240 DTC_Enable, 20->DTC_ENABLE_13->CL15on-DTCon - BD enabled (default is CL15on-DTCon - BD disabled)

The following codes are a matter of preference:

NIV 3253 Pedestrian_4, 80 BD_MINIMUM_SPEED Werte=00 (default is Werte=08)

This will allow detection of pedestrians at any speed. Normally this is only active at speeds of 8 mph or higher.

NIV->3000 Basic_Functions, 20->Light_Sensor->ON_WITH_PWR_ON (default is ON_WITH_RLS_INFO)

This will allow the camera to be on (standby) as soon as you turn the car on. The default is the camera on when it is dark outside.

This will increase dramatically the usefulness of the Night Vision System. You do not need to actively turn it on to gain the benefit of pedestrian warnings.

None of these code changes are possible without the resources, tools and advice provided by Shawn, Sean and others.

JEG23
 

·
Registered
Joined
·
314 Posts
djsaad1,

Thanks for the credit, but it is really hard to discover a new code if it does not work in your own car :)

You did all the testing and troubleshooting.

JEG23
 

·
BMW Enthusiast
Joined
·
195 Posts
Thanks for the hard work JEG23. And thanks for sharing djsaad1. Code works flawlessly. Highly recommended to any members with NV.
 

·
BMW Enthusiast
Joined
·
195 Posts
After a couple of weeks of full-time background pedestrian detection, I have gotten very used to having the system constantly on the lookout for pedestrians in the scanning range of the vehicle and responding with the appropriate alerts. Simply delightful.

However, in the last two days, the system has stopped detecting pedestrians. When the NV displayed is turned on, there is a yellow triangle symbol in the bottom left corner indicating the Pedestrian Detection is unavailable. Clicking on iDrive to try re activating it is to no avail. After a two days of trial and error, with intermittent success, it became apparent that the system becomes unavailable when the external temperature exceeds 30.5 degrees Celsius. As it is summer now, hitting that temperature is quite common.

For those of you who have coded background pedestrian detection, please bear this in mind should the function suddenly refuse to activate. There is nothing wrong with it. Will try to look for the code that allows us to raise this threshold.
 

·
Registered
Joined
·
314 Posts
After a couple of weeks of full-time background pedestrian detection, I have gotten very used to having the system constantly on the lookout for pedestrians in the scanning range of the vehicle and responding with the appropriate alerts. Simply delightful.

However, in the last two days, the system has stopped detecting pedestrians. When the NV displayed is turned on, there is a yellow triangle symbol in the bottom left corner indicating the Pedestrian Detection is unavailable. Clicking on iDrive to try re activating it is to no avail. After a two days of trial and error, with intermittent success, it became apparent that the system becomes unavailable when the external temperature exceeds 30.5 degrees Celsius. As it is summer now, hitting that temperature is quite common.

For those of you who have coded background pedestrian detection, please bear this in mind should the function suddenly refuse to activate. There is nothing wrong with it. Will try to look for the code that allows us to raise this threshold.
andreo,

I had noticed that too and I am sorry I failed to mention it in the write up. The pedestrian detection is pretty useless in Texas for long periods of the year. I tried to see if there were codes to change this, but I did not find any. I suspect is an issue of heat differential between the environment and humans when it is hot. Maybe you can find something.

JEG23
 

·
BMW Enthusiast
Joined
·
195 Posts
Thanks JEG23.

I tried messing around with some of the parameters with TEMP in the name to no avail. Will keep looking. It will be interesting to see how the system responds in winter.
 

·
Registered
Joined
·
11 Posts
Anyone figure out how to get this working on the F10? I heard it is only working on the M6. Have not tried it myself yet.
 

·
Registered
Joined
·
314 Posts
Anyone figure out how to get this working on the F10? I heard it is only working on the M6. Have not tried it myself yet.
avlnch,

It did not work at least on my 2011 F10. Give it a try and let us know.

JEG23
 

·
BMW Enthusiast
Joined
·
195 Posts
Anyone figure out how to get this working on the F10? I heard it is only working on the M6. Have not tried it myself yet.
Djsaad1 and I got it working successfully on a F06 and a F13 respectively. Hope it works for you too.
 

·
BMW Enthusiast
Joined
·
195 Posts
Plan on trying this when I am back in town. I'll report back after I code it, hopefully all goes smooth.
Great. Hope you get it up and running soon. I have recently witnessed it working during daytime as well after setting LIGHT_SENSOR to ON_WITH PWR_ON. Give it a try.

Sent from BimmerApp mobile app
 

·
Groccery Getter
Joined
·
264 Posts
I did this the other day and for some reason it only shows the warning on the idrive screen and the dash. It doesn't show up on my heads up display screen? :dunno: Going to recheck if all the value's are correct.
 

·
Registered
Joined
·
115 Posts
Hello everybody!
Tried this on my F10 - no visible changes ;-) If you launch system - it still writes icon that person is not active.
But, in background it works and shows the warnings
 

·
Premium Member
Joined
·
40,930 Posts
Do you have S611A BMW Night Vision or S6UKA Night Vision with human recognition in your FA?
 

·
Registered
Joined
·
115 Posts
Hello again!
Yes, i need to change my answer! It works!
Yesterday during lond trip during day car showed me the warning!
My previous post and misunderstanding was because when i launch system in normal way during daytime, it still shows yellow icon, that pedestrian recognition doesn't work, and don't highlight people with yellow color!

But yes, on DKOMBI and HUD it now show warning, as should!
So, confirmed! It's working ))

Even on my F10, with retrofitted NiVi - thanks to Dipo71 for that =)
 

·
Registered
Joined
·
66 Posts
Hello again!
Yes, i need to change my answer! It works!
Yesterday during lond trip during day car showed me the warning!
My previous post and misunderstanding was because when i launch system in normal way during daytime, it still shows yellow icon, that pedestrian recognition doesn't work, and don't highlight people with yellow color!

But yes, on DKOMBI and HUD it now show warning, as should!
So, confirmed! It's working ))

Even on my F10, with retrofitted NiVi - thanks to Dipo71 for that =)
:thumbup:
 

·
Registered
Joined
·
115 Posts
No way, only warnings from nivi can be show on HUD
 
1 - 20 of 41 Posts
Top