BimmerFest BMW Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Well I just finished installing new factory struts, upper strut bushing, lower new rubber for strut seat, and bump stops. All items I got from the dealer and yes I got a great deal on them since they told me when I bought the car the struts were fine and they both were shot after I had the car inspected. Anyways I have a rattle in the struts kind of sound like them moving around. I have installed suspensions on everything from Ford, GM, and VW so I am familiar with how they mount and I am sure that is correct. But I am new to the BMW world and was wondering if this is just something you deal with after adding new parts until they are broken in?:dunno:
Also how can I tighten up the emergancy brake cable because I have a 5 spd. and the e-brake don't hold very well at all and I don't like the tranny being the brake for the car. Great board and thanks.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #2 ·
I think I fixed it! I drove it then came back jacked it up pulled the tires retightened everything and dropped it back down..now it's sounds...........Quite!
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #3 ·
I think I fixed it! I drove it then came back jacked it up pulled the tires retightened everything and dropped it back down..now it's sounds...........Quite!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top