BimmerFest BMW Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hello everyone,
I got a problem maybe someone has encountered it, 3 days ago the "chassis fuction restricted" appeared and it keeps appearing at aprox 10sec i start the car, later that day wile i was driving the error dissapeared for a couple of minutes and then appeared again, i deleted all the faults with ista+ but 7 still remain meaning there is a persistent problem, here is the screenshot with the faults, i also checked fuse f153
 

Attachments

·
Registered
Joined
·
25 Posts
Discussion Starter #2 (Edited)
Well i found some of the issues, i searched for the ehc in the trunk and it seems that some water corroded one of the pins, even tho i could not understand how water got there (under the fuse box area) seems like it was an old problem.
Currently wainting for the ehc replacement module, now i need to find what's causing ihka, fka, smfa, smbf faults.
Attached pics are from the ehc module
 

Attachments

·
Super Moderator
Joined
·
8,332 Posts
I would think you could have some fuses blown, or a PCB has shorted out. If the CanBus system is not communicating, it can be a hard long day searching for the problems?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
Well i checked the fuses and i'm not getting off that easy ***x1f615; the first 3 faults are because of the ehc module wich i'm waiting to receive. The fk is for the rear ac control module, wich doesnt work anymore, it used to switch on and off randomly, i'm thinking there is a short on the cable behind the module, hopefully. I'll try to remove it when i have a little free time.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
Yesterday i got the ehc replacement, now i need to figure out how to code it since it came from another car, does anyone know if it can be done in inpa?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
I finally managed to code the module with esys so everything is ok, need to finnish my soft close project now ***x1f642;
 

·
Registered
Joined
·
4 Posts
Yesterday i got the ehc replacement, now i need to figure out how to code it since it came from another car, does anyone know if it can be done in inpa?
I know this is an old thread, but what did you use to code the replacement EHC module. I did the same, and using ISTA/P I thought it programmed as my original module but it does not seem to work correctly.
 

·
Super Moderator
Joined
·
8,332 Posts
You have to write in you vin number to the module to program it correctly. ESYS does coding, & can be found in our coding forum here. ISTA/P is for E Series models. ISTA+ has the programming built into it starting with the F Series models.

 

·
Registered
Joined
·
4 Posts
You have to write in you vin number to the module to program it correctly. ESYS does coding, & can be found in our coding forum here. ISTA/P is for E Series models. ISTA+ has the programming built into it starting with the F Series models.

Thanks Herb! I have an E61, I know I meandered across the fence on this one but was hoping the solution here might still work for me. :confused:
 
1 - 9 of 9 Posts
Top