Bimmerfest BMW banner

1 - 20 of 24 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I've only had my 1999 523 for less than a week and im having trouble with the OBC. The dash side of it works ok but i cant seem to get into any of the functions on the display panel apart from the time and date. Either im doing something wrong, it doesnt have that function there or theres a fault. It has climate and a BMW Business stereo. I've tried pressing and holding both BC buttons but this doesnt seem to do anything. Any help would be appreciated. Thank you in advance.

Pete
 

·
Registered
Joined
·
598 Posts
peteherts said:
I've only had my 1999 523 for less than a week and im having trouble with the OBC. The dash side of it works ok but i cant seem to get into any of the functions on the display panel apart from the time and date. Either im doing something wrong, it doesnt have that function there or theres a fault. It has climate and a BMW Business stereo. I've tried pressing and holding both BC buttons but this doesnt seem to do anything. Any help would be appreciated. Thank you in advance.

Pete
what type od the computer do You have, is it the large version (MID) or smaller (IRIS)
Do you have the button marked "BC" ?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Thanks for your reply. I have two buttons marked BC, one on the indicator stick and the other to the right of the radio/tape/CD display. On the left of the button is a clock and on the right is the BC letters. The stereo book that came with the car seems to be the original one and its a BMW Business stereo. The dispaly is just above the dual climate control. To be honest im not sure what type of computer it is.
 

·
Registered
Joined
·
598 Posts
peteherts said:
Thanks for your reply. I have two buttons marked BC, one on the indicator stick and the other to the right of the radio/tape/CD display. On the left of the button is a clock and on the right is the BC letters. The stereo book that came with the car seems to be the original one and its a BMW Business stereo. The dispaly is just above the dual climate control. To be honest im not sure what type of computer it is.
Ok and if you press on the BC next to the clock symbol, this should bring some options
to the display above the radio/computer buttons, does it?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Its the same display apart from the audio dsp doesnt have the dsp part, there isnt a telephone button and the climate is different. Hope that helps.

Pete
 

·
Registered
Joined
·
598 Posts
Then that's the MID You have

Something went wrong with communication between the instrument cluster and the MID.

So i presume that when you use the BC button on the turn signal stalk you get all the
functions, consumption, remaining miles, and so on?

Did it ever work or was it inop since ever?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #9
Yep the one works on the stalk ok. I only got the car Wednesday and have only just started looking at what it does. All i can do at the moment is use the stalk as normal, change the time and date and use the radio/cd/tape. Someone did suggest taking the fuses out for it and seeing if that reset it so i'll try that tomorrow but i really wanted to confirm it should do all the stuff it was supposed to do and if maybe i was doing something wrong.
 

·
Registered
Joined
·
598 Posts
Let's try it the other way: when You change the radio station/cd whatever you have, do
You get the audio sources indication on the instrument cluster?

The issue might be solved by the "old reset trick" that we have discussed here day or
two ago - disconnect the battery for 10 minutes and reconnect it firmly back.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
I get the radio/cd sources on the on the centre display (MID) but not on the dashboard (if thats what you mean by instrument cluster).
I had to reset the key so i know not everything was perfect when i got it but it would be nice to have the other functions working aswell.
 

·
Registered
Joined
·
598 Posts
Hmm, then do you get *anything* on the center display? any "softbutton" captions,
audio functions, anything?

Sorry for all the questions, trying to understand what the problem really is
 

·
Registered
Joined
·
598 Posts
Sorry it's 1:00AM here and i got your message right this time, ok seems like
you either need to reset the electronics by removing power or try to
check the MID connections at the back - it is very easy

remove the volume knob and with small hex tool unlock the latch
that holds MID in the center console then you can take it out - check all connections
if they are tight

if this and battery trick won't help get it computer diagnosed. I don't know whats Your
situation but perhaps it would be good to complain about it to the PO/seller
 

·
Registered
Joined
·
15 Posts
Discussion Starter #15
Thank you that gives me three or four things to try tomorrow and hopefully it will be one of the first three cos the fourth will be expensive lol. The seller was private and sold as seen and in this world we cant expect everything to be perfect.

Pete
 

·
Registered
Joined
·
15 Posts
Discussion Starter #16
I've tried looking at the fuses and doing the battery reset but to no avail. I'll have to get me mate to look at the MID part because he has the tools to do that.
 

·
Registered
Joined
·
598 Posts
I hope that your MID will be fixed soon. If the MID connections are OK then get it computer
diagnosed - it has its own memory and error codes can be pulled from it. Perhaps it
got somehow disconnected from one of the buses.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #18
Thanks i hope so too cos it would be nice to have the other functions. Even without those its a fantastic car and im really happy i got it. Maybe its just something silly im not doing. I've even tried switching the radio off then on and pressing the memory button for 10 seconds as that brings up other functions but nothing that helps
 

·
Registered
Joined
·
598 Posts
peteherts said:
Thanks i hope so too cos it would be nice to have the other functions. Even without those its a fantastic car and im really happy i got it. Maybe its just something silly im not doing. I've even tried switching the radio off then on and pressing the memory button for 10 seconds as that brings up other functions but nothing that helps
It should be available right away, no tricks involved. I've owned 9 cars till now including
360HP loaded with electronics Mercs but the Bimmer is truly the best driving machine i've
ever got.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #20
Must be honest and say i saw one before i bought this and it let down in the way i though they were but after getting this is has restored my faith. Just looking at the previous bills i see has has recently had a clutch, rear and front pads replaced, oil service and fault fault resolved with the abs/traction control so i cant complain really
 
1 - 20 of 24 Posts
Top