BimmerFest BMW Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
252 Posts
Discussion Starter · #1 ·
This started yesterday, turn my 97 328i on and the climate controls don't always turn on, the box stays black, pressing buttons does nothing.

Other times when I start the car the thing turns on and works fine

The other odd part is while driving today the thing stayed on, was working fine and all of the sudden all the blowers and every thing turned off, the screen stayed on (60 deg with AC) nothing came out, and no buttons did anything. A few min later everything went back to normal.


No blown fuses, connections look fine, is it possible the unit just needs to be replaced?

Thanks now for any help
 

·
Registered
Joined
·
12,957 Posts
The solder joints on the circuit card inside the unit get brittle over time and crack. When that happens you get intermittent function. If you're handy with electronics there are DIYs for touching up some of the key solder joints to try and fix it.
 

·
Registered
Joined
·
1 Posts
I've had the same exact problem on my 1996 328i. I've found it works the worst in cold and hot temps (when I need it the most!) but stays on during moderate temperature days. Dexter, did you end up replacing the unit?
 

·
BMW CCA Member
Joined
·
3,419 Posts
i have a replacement unit, I haven't installed it yet.
Then why did you create this thread in the first place? :rofl::rofl:

But yeah, before you install the new unit, may want to go over the solder points once to re-seat the solder.


Send your donations in cash. :thumbup:
 

·
Cruising 280 Top Down
Joined
·
6,089 Posts
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top