Bimmerfest BMW banner

1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi all,

On a 2008 520D, I have one of my front PDC sensors that just goes off all the time. It isn't doing the "clicking" that indicates a failure (From what I have read) but nonetheless is very annoying.
So, I researched a new sensor, ordered it, removed the front bumper and went to replace it, but alas, I found that the plug was wrong.
Now, I have searched high and low and I cant find an e60 PDC sensor with a plug setup like mine so I hoped someone might be able to help me with where to get one of these...
(I put the old one back and put the front bumper back on without realising I had minimal photos and no part number).

So, first time I have put up a pic, so not sure if this will work.... But, reality, my plug has three pins straight across versus the "normal" has the middle pin higher than the others.

 

Attachments

·
Registered
Joined
·
2,428 Posts
There should be a part number on the sensor. It may be very faint but it's laser etched on the side. If you go to realoem.com you can check both the part number and based on your VIN, find the OEM BMW part. The replacement in your picture looks like a sensor for Japanese cars.

You should also verify the wiring harness because sometimes the wires get pinched or chafed, then break due to corrosion.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Thanks for the response. I think you are right and pulling it back out to check might be my only option...
I was hoping to not have to pull it all apart again until I have a new one ready to go in.

I had a good look at the wires and the sensor when I took it out and all seems to be fine..
 

·
Registered
Joined
·
22 Posts
Discussion Starter #5
Yeah. I couldn't manage it the first time (couldn't figure out how to disconnect it) and had to pull off the bumper, but now I have done it once, you are probably right!
 
1 - 5 of 5 Posts
Top