BimmerFest BMW Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I recently bought a 2006 E64 650i. Very pleased with it, 100k miles and an absolute steal as the car had a few problems I have either fixed or am fixing.

One of said problems is the PDC sensors. I replaced all the rear sensors with cheap ones from the Far East as at least two had failed so PDC wouldn***8217;t work at all; and the PDC now activates, but now when I reverse the sensors at the far sides do not ***8216;see***8217; anything and the ones in the middle only pickup objects which are about two inches away.

Should I try sensors from BMW (approx £100 each) or the wiring harness or both?

I know the car has had water damage from blocked drains in the past, but the PDC controller is fine (tested in another vehicle).
 

·
Super Moderator
Joined
·
1,883 Posts
Chances are it's the cheap sensors that are giving you problems, that said, if the "other test vehicle" is still available then you could test the sensors to completely rule out any possible wiring loom issues. The fact that the middle ones are only seeing objects two inches away doesn't bode well though, I'm assuming you haven't painted these as that too can give problems depending on the thickness and type of paint used, you could try a light solution of paint thinner to knock down a bit of the paint/clear thickness to see if the distance improves, their useless with a two inch range anyway so you've nothing to loose.
 

·
Super Moderator
Joined
·
8,333 Posts
The PDC problems are usually caused by bad sensors, or the wiring harness is old, & has broken due to someone pulling the bumper cover off & not closely paying attention to the PDC sensors. Hold your finger on each sensor why the PDC is activated. If the sensor is working properly, you will feel a faint bump on the sensor. As stated above, you can not paint the sensors. Most German sensors are made by the same company that supplies all of the German Auto brands. The paint color is the thing to pay close attention when buying used.

The wiring harness is around 80 to 100.00 from BMW, & the bumper cover will need to be pulled to install the new harness.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Thanks for the replies. Unfortunately the test vehicle was my old E60, which has now gone to the big carpark in the sky. The sensors haven***8217;t been painted and I was careful when fitting them (didn***8217;t remove the bumper completely, just pulled it forwards a couple of inches).

Guess I***8217;ll replace the sensors with genuine BMW and then the harness if still getting problems. Lesson learnt on the cheap sensors!
 

·
Super Moderator
Joined
·
8,333 Posts
Your old sensors might be good, but the wiring harness is probably damaged. It will check good with VOM, but it can still be damaged.
 

·
Registered
Joined
·
2 Posts
Hi. I'm also having issues with my PDC. Can't activate, using the button on the centre console, but car isn't showing any warnings. Can someone tell me where to locate the PDC module as I think this might be the issue. Thanks.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
The PDC module is next to the battery in the boot. It has three connectors that go to it.
 

·
Registered
Joined
·
2 Posts
The PDC module is next to the battery in the boot. It has three connectors that go to it.
Thanks very much. Took the module out and gave it a spray with contact cleaner, and to my disbelief all working as good as new!:thumbup::thumbup:
 

·
Super Moderator
Joined
·
1,883 Posts
Thanks very much. Took the module out and gave it a spray with contact cleaner, and to my disbelief all working as good as new!:thumbup::thumbup:
I've not heard of that working on the module itself before, nice find and worth remembering for future people with these problems.
Its nearly always the sensors or the harness, glad you got yours sorted good work :thumbup:.
 
1 - 10 of 10 Posts
Top