BimmerFest BMW Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter · #1 ·
Well i just ran the peake reader(R5-fcx-II) on my 97 540i and to say the least im overwhelmed.:cry: I dont know where to begin help please thanks a million. Here are the results as found in Table 06 of the manual p.12-13.

Peake codes 1997 540i

Table 06:
8b-Electric thermostat control final stage
3E-Misfire detected, random or unknown cylinder
36-Misfire detected, cylinder #5
35-Misfire detected, cylinder #4
34-Misfire detected, cylinder #3
38-Misfire detected, cylinder #7
32-Misfire detected, cylinder #1
46-Misfire detected, catalyst damaging, cylinder #8
43-Misfire detected, catalyst damaging, cylinder #5
42-Misfire detected, catalyst damaging, cylinder #4
41-Misfire detected, catalyst damaging, cylinder #3
45-Misfire detected, catalyst damaging, cylinder #7
d5-Knock sensor cyl, 7-8
23-Fuel trimm QL additive Cyl 5-8
39-Misfire detected, cylinder #8
33-Misfire detected, cylinder #2
46-Misfire detected catalyst damaging Cyl #8
7b-Coolant temp sensor
3f-Misfire detected catalyst damaging cylinder #1
40-Misfire detected catalyst damaging cylinder #2
 

·
Double D
Joined
·
148 Posts
Hey Red,
I can't recall the misfire codes my Peake gave me, but I pulled the Coil Packs and ran a resistance check on them...All were faulty! After replacing all six Coil Packs, no more misfire codes! Could be a spate of other issues of course. But if you have the Bentley repair manual, look and see what the resistance should be and see if they fall within said parameters. As for knock sensor and coolant temp sensor, I would guess that they are also faulty. Again, based soley on what I've experienced. Have no idea on the other codes! Good luck and report back with your findings...if you decide to tackle it yourself! Heck, even if you don't, give us the 911 for future reference...
 

·
Older than old school
Joined
·
4,461 Posts
It might help if you list your car's symptoms.
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #4 ·
It might help if you list your car's symptoms.
Well on startup it idles really rough like it stumbles and seems like it will stall but after warming up it stops. It leaks from what seems to be the left side of the radiator/reserve tank. There is coolant on top of the reserve tank rim. It died on me a couple of days on a very short trip to wendys, all of a sudden i felt a loss of power, when i gassed it there was no power, it wouldnt rev. I stopped the motor restarted and tried to drive it wouldnt drive it would creep forward like 1 mph so i stopped. Got it towed home and thats it.
 

·
Freude am Fahren
Joined
·
6,378 Posts
It might help if you list your car's symptoms.
Looking at the codes says it all...

Coils, spark plugs, or particularly bad gas could cause this. No Diesel in the tank, right?
 
1 - 6 of 6 Posts
Top