BimmerFest BMW Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
I just bought a 1989 325i automatic with 100,000 miles on it, in absolute MINT condition. I test drove it two days in a row, and it ran beautifully. I wasn't really in the market for a new car, but I took the plunge anyway. The SECOND day I had it, I drove it all around town running errands for about 3 hours, and everything was great. On the way home, once I got off the interstate and was stopped waiting to turn off the exit ramp, the engine cut off. I put the car in park, turned off the ignition, and tried to start it. It started right back up. About 10 miles later, while I was stopped at a stoplight, the same thing happened...only this time it wouldn't start again. We had the car towed to a BMW mechanic, and he diagnosed the problem as the idle control valve, replaced it, and called me to pick the car up two days later.

The day I picked it up, I drove it around town, running errands, and was extremely happy with the engine performance. However, on the way home, AGAIN, the engine cut off at another stoplight. It did this same thing 4 more times before I finally made it home.

The car is with the BMW mechanic right now, and he has been driving it for 4 days. It hasn't done anything out of the ordinary, and he can't seem to find anything wrong with it.

What's going on? Any ideas?

I love the car too much to give it up without a fight.
 

·
another E30 nut
Joined
·
916 Posts
They are nice cars. My old 325E had fuel pump problems. It would do the same thing but when it went to die, If you smacked the backseat the pump would resume its job.
Seeing as how pumps are only 100$ its worth the investment.
It could be one of many things.
Keep us posted on the results.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
no we just put a full tank of gas in it...

i was reading some other threads and picked up a few ideas of what the problem might be:

frayed engine reference sensor
fuel pump
problems with air intake

any thoughts??
 

·
On Top
Joined
·
8,772 Posts
alhahla said:
no we just put a full tank of gas in it...

i was reading some other threads and picked up a few ideas of what the problem might be:

frayed engine reference sensor
fuel pump
problems with air intake

any thoughts??
All of those are likely to cause your issue. Good luck and welcome to the board.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
i am still in contact with the dealer and keeping him updated on the situation. he is willing to refund the purchase price if we decide to abandon ship. how much is too much to put into this car before calling it quits?
 

·
Registered
Joined
·
50 Posts
My car quit running while driving and never started again.
After lookin at relays, installing the reserve pump and forever testing both pumps I got the car to run by hooking the pump directly to the battery.
Anyway, it turned out to be the plug at the pump was not making good connection.

Just an illustration of goofy things that can happen and can potentially cost a bundle when your trustworthy mechanic keeps replacing components.
 

·
Registered
Joined
·
1,300 Posts
get a Bentley's manual and start diagnostics and repairs on your own. You'll be suprized how easy and rewarding it is. I look at my car as a hobby. It's a daily driver, but when it's down I take the bus or ride my motorcycle. I guess if you need a real dependable car for work or something...this may not be the right car until you isolate the issue...I hope you keep it and don't give up....they aren't making them any more.
 

·
Registered
Joined
·
478 Posts
Here's my $.02 and that's probably all its worth. If I read right, when you say your engine CUTS out. To me means fast stop. I think thats electrical myself.
 

·
Registered
Joined
·
302 Posts
Hi PuebloPete...

Sounds like you got what I had and mentioned above - frayed reference sender. I too was told it was the idle control valve by my mechanic and that obviously wasn't it. Ask them to check that out (if you haven't already)....here's my thread:

http://www.bimmerfest.com/forums/showthread.php?t=157811

Good luck and welcome!

PS> would love to see some mint pics ! :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #11 ·
i would love to take the car on as my own little project, while i still have something else to drive. where do i get a bentley's manual?
 

·
Registered
Joined
·
676 Posts
Good story.
 

·
Registered
Joined
·
1,972 Posts
Where in VA are you? NOVA here.

Anyway quick question you mention it cuts out while you are at stop lights and signs and it's a auto. So it's a load thing. Have you tried shifting to neutral while at a light? does it die?

Did your mechanic clean the throttle body, and the afm and the ICV?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #15 ·
i didn't have a chance to try shifting it into neutral before i took it to the mechanic. i guess the reason he thought it was the idle control valve is that it usually quit running when my foot was off the accelerator for an extended period of time. it would idle really high, shudder a few times, blow a little black smoke out of the exhaust, and crap out. the first time it ever happened, there was a really strong smell of gasoline...but that hasn't happened any of the other times.

and to your second question, i'm not sure if he cleaned those. i'd have to ask him.
 
1 - 15 of 15 Posts
Top