BimmerFest BMW Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1 (Edited)
Hi guys,

First time poster here, long term lurker. I've recently attempted a pixel repair on my E39 525i, which was daunting to me, but successful. The only issue is that I believe I have somehow damaged or altered the starting position for the motor driving the fuel gauge, and now it appears to max out at ~40 litres, even though the tank is full (~70L). The range in the obc reflects this, showing ~500km, instead of the expected ~800km. I tried a search, but I couldn't find any fixes relating to the cluster, only the floats & siphon pump, which I don't believe are related. The fuel gauge seems offset, with it's position when the vehicle is "off" pressing against the side of the gauge. I have attached pictures, if anybody is able to advise on how to fix the issue (short of a new cluster), it would be greatly appreciated. Cheers! :)

Car off:



Key Position 2:



[FIXED]
Accidentally stumbled across the fix on another forum, it is apparent that it's perfectly fine to turn the needle past the point of resistance to manually alter it's "zero" position.

Credit here:
http://forums.bimmerforums.com/forum...ads-past-empty
 

·
Registered
Joined
·
15,583 Posts
I'm not familiar with that repair. Did you remove the needle? Perhaps you need to re-position it at zero.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks for the reply,

I should have noted, I replaced the ribbon cable, which restored pixel functionality in the high-obc. It appears I reset the obc, hence the range was estimated from purely driving to the petrol station, but now reflects a full tank.

I did not remove the needles, and I tried my best not to let them become impacted during the repair, would it be fine just to push it past it's point of resistance to have it placed back at the "0" value on the dial? Or will this break something. Apologies, I'm not the best mechanic haha. Cheers!
 

·
BMW forever
Joined
·
1,278 Posts
Same happened to my temp needle, went 1 mm past 12 but temp was85 on the OBC so i bent !! the needle just enough to set it strait. No problem and allis working good.
 
1 - 5 of 5 Posts
Top